首页 > 代码库 > Max Sum
Max Sum
/*Max Sum
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 147728 Accepted Submission(s): 34527
Problem Description
Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
Sample Input
2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5
Sample Output
Case 1:
14 1 4
Case 2:
7 1 6
*/
//思路:i=0,sum=0;如果sum+=s[i+1]>s[i],max=sum记下下标起始点d1,继续s+=s[i+2]与s[i+2]比较,如果s[i+2]为正数,max=s,末标识点d2=i;反之max=max;
//当sum<0时,起始标记点下标加1,sum重新置0;
#include<stdio.h>
int s[100003];
int main()
{
int i,T,n,kase;
scanf("%d",&T);
for(kase=1;kase<=T;kase++)
{
scanf("%d",&n);
for(i=1;i<=n;i++)
scanf("%d",&s[i]);
int sum=0,f1=1,max=s[1];
int d1=1,d2=1;//注意d1=d2=1;
for(i=1;i<=n;i++){//该题关键!!!
sum+=s[i];
if(sum>max)
{
max=sum;
d1=f1;
d2=i;
}
if(sum<0)
{
sum=0;
f1=i+1;
}
}
printf("Case %d:\n",kase);
printf("%d %d %d\n",max,d1,d2);
if(kase!=T)
printf("\n");
}
return 0;
}
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 147728 Accepted Submission(s): 34527
Problem Description
Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
Sample Input
2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5
Sample Output
Case 1:
14 1 4
Case 2:
7 1 6
*/
//思路:i=0,sum=0;如果sum+=s[i+1]>s[i],max=sum记下下标起始点d1,继续s+=s[i+2]与s[i+2]比较,如果s[i+2]为正数,max=s,末标识点d2=i;反之max=max;
//当sum<0时,起始标记点下标加1,sum重新置0;
#include<stdio.h>
int s[100003];
int main()
{
int i,T,n,kase;
scanf("%d",&T);
for(kase=1;kase<=T;kase++)
{
scanf("%d",&n);
for(i=1;i<=n;i++)
scanf("%d",&s[i]);
int sum=0,f1=1,max=s[1];
int d1=1,d2=1;//注意d1=d2=1;
for(i=1;i<=n;i++){//该题关键!!!
sum+=s[i];
if(sum>max)
{
max=sum;
d1=f1;
d2=i;
}
if(sum<0)
{
sum=0;
f1=i+1;
}
}
printf("Case %d:\n",kase);
printf("%d %d %d\n",max,d1,d2);
if(kase!=T)
printf("\n");
}
return 0;
}
Max Sum
声明:以上内容来自用户投稿及互联网公开渠道收集整理发布,本网站不拥有所有权,未作人工编辑处理,也不承担相关法律责任,若内容有误或涉及侵权可进行投诉: 投诉/举报 工作人员会在5个工作日内联系你,一经查实,本站将立刻删除涉嫌侵权内容。