首页 > 代码库 > HDU - 5050 Divided Land

HDU - 5050 Divided Land

Problem Description
It’s time to fight the local despots and redistribute the land. There is a rectangular piece of land granted from the government, whose length and width are both in binary form. As the mayor, you must segment the land into multiple squares of equal size for the villagers. What are required is there must be no any waste and each single segmented square land has as large area as possible. The width of the segmented square land is also binary.
 

Input
The first line of the input is T (1 ≤ T ≤ 100), which stands for the number of test cases you need to solve.

Each case contains two binary number represents the length L and the width W of given land. (0 < L, W ≤ 21000)
 

Output
For each test case, print a line “Case #t: ”(without quotes, t means the index of the test case) at the beginning. Then one number means the largest width of land that can be divided from input data. And it will be show in binary. Do not have any useless number or space.
 

Sample Input
3 10 100 100 110 10010 1100
 

Sample Output
Case #1: 10 Case #2: 10 Case #3: 110

题意:求二进制的最大的正方形

思路:java大数函数都有

import java.math.BigInteger;
import java.util.Scanner;

/**
 * Created by acer on 14-9-27.
 */
public class Main {

    public static void main(String[] args) {
        Scanner sc = new Scanner(System.in);
        int t;
        String a;
        String b;
        BigInteger c;
        BigInteger A;
        BigInteger B;
        t = sc.nextInt();
        for (int cas = 1;  cas <= t; cas++) {
            A = sc.nextBigInteger(2);
            B = sc.nextBigInteger(2);
            System.out.print("Case #" + cas + ": ");
            System.out.println(A.gcd(B).toString(2));
        }
    }
}



HDU - 5050 Divided Land