首页 > 代码库 > POJ 1328 Radar lnstallation 2
POJ 1328 Radar lnstallation 2
Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d.
We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates.
Figure A Sample Input of Radar Installations
Input
The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases.
The input is terminated by a line containing pair of zeros
Output
For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case.
Sample Input
3 2
1 2
-3 1
2 1
1 2
0 2
0 0
Sample Output
Case 1: 2
Case 2: 1
贪心:注意重点
#include<iostream>
#include<cstring>
#include<algorithm>
#include<cstdio>
#include<cmath>
using namespace std;
int f[1010];
struct aa
{
double x,y;
}a[1010];
int cmp(aa q,aa w)
{
return q.x<w.x;
}
int main()
{
int k,n,m,cnt,ka=0;
while(cin>>n>>m)
{ if(n==0&&m==0)break;
ka++;
int flat=1;
k=0;
double x,y,c,mm=(double)m*m;
for(int i=1;i<=n;i++)
{
cin>>x>>y;
if(m>=y)
{c=sqrt(mm-y*y);
a[++k].x=x-c;
a[k].y=x+c;
}
else
{
flat=0;
}
}
getchar();
if(flat)
{sort(a+1,a+k+1,cmp);
double now = a[1].y;
cnt = 1;
for(int i=2;i<=k;i++)
{
if(a[i].y<now)
now=a[i].y;
else if(a[i].x>now)
{
cnt++;
now=a[i].y;
}
}
}
else
cnt=-1;
cout<<"Case "<<ka<<": "<<cnt<<endl;
}
return 0;
We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates.
Figure A Sample Input of Radar Installations
Input
The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases.
The input is terminated by a line containing pair of zeros
Output
For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case.
Sample Input
3 2
1 2
-3 1
2 1
1 2
0 2
0 0
Sample Output
Case 1: 2
Case 2: 1
贪心:注意重点
#include<iostream>
#include<cstring>
#include<algorithm>
#include<cstdio>
#include<cmath>
using namespace std;
int f[1010];
struct aa
{
double x,y;
}a[1010];
int cmp(aa q,aa w)
{
return q.x<w.x;
}
int main()
{
int k,n,m,cnt,ka=0;
while(cin>>n>>m)
{ if(n==0&&m==0)break;
ka++;
int flat=1;
k=0;
double x,y,c,mm=(double)m*m;
for(int i=1;i<=n;i++)
{
cin>>x>>y;
if(m>=y)
{c=sqrt(mm-y*y);
a[++k].x=x-c;
a[k].y=x+c;
}
else
{
flat=0;
}
}
getchar();
if(flat)
{sort(a+1,a+k+1,cmp);
double now = a[1].y;
cnt = 1;
for(int i=2;i<=k;i++)
{
if(a[i].y<now)
now=a[i].y;
else if(a[i].x>now)
{
cnt++;
now=a[i].y;
}
}
}
else
cnt=-1;
cout<<"Case "<<ka<<": "<<cnt<<endl;
}
return 0;
}
POJ 1328 Radar lnstallation 2
声明:以上内容来自用户投稿及互联网公开渠道收集整理发布,本网站不拥有所有权,未作人工编辑处理,也不承担相关法律责任,若内容有误或涉及侵权可进行投诉: 投诉/举报 工作人员会在5个工作日内联系你,一经查实,本站将立刻删除涉嫌侵权内容。