首页 > 代码库 > HDU - 2825 Wireless Password(AC自动机+DP)
HDU - 2825 Wireless Password(AC自动机+DP)
Description
Liyuan lives in a old apartment. One day, he suddenly found that there was a wireless network in the building. Liyuan did not know the password of the network, but he got some important information from his neighbor. He knew the password consists only of lowercase letters ‘a‘-‘z‘, and he knew the length of the password. Furthermore, he got a magic word set, and his neighbor told him that the password included at least k words of the magic word set (the k words in the password possibly overlapping).
For instance, say that you know that the password is 3 characters long, and the magic word set includes ‘she‘ and ‘he‘. Then the possible password is only ‘she‘.
Liyuan wants to know whether the information is enough to reduce the number of possible passwords. To answer this, please help him write a program that determines the number of possible passwords.
For instance, say that you know that the password is 3 characters long, and the magic word set includes ‘she‘ and ‘he‘. Then the possible password is only ‘she‘.
Liyuan wants to know whether the information is enough to reduce the number of possible passwords. To answer this, please help him write a program that determines the number of possible passwords.
Input
There will be several data sets. Each data set will begin with a line with three integers n m k. n is the length of the password (1<=n<=25), m is the number of the words in the magic word set(0<=m<=10), and the number k denotes that the password included at least k words of the magic set. This is followed by m lines, each containing a word of the magic set, each word consists of between 1 and 10 lowercase letters ‘a‘-‘z‘. End of input will be marked by a line with n=0 m=0 k=0, which should not be processed.
Output
For each test case, please output the number of possible passwords MOD 20090717.
Sample Input
10 2 2 hello world 4 1 1 icpc 10 0 0 0 0 0
Sample Output
2 1 14195065
题意:让你构造一个长度为n的字符串,使得至少包含共m个的集合里的k个,求个数。
思路:AC自动机构造,需要用到DP的思想,设dp[i][j][k]表示长度为i到达自动机状态为j的时候且状态k时的个数。我们需要用一个来表示状态j包含的字符串的个数,也就是走到字符串末尾的个数,二进制表示。然后还要注意一点的是:我们在构造自动机的时候有fail指针的转移,所以状态j也需要结合它失配时候的状态。
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <queue>
using namespace std;
const int mod = 20090717;
int n, m, k;
int dp[30][250][1<<10];
int num[5000];
struct Trie {
int nxt[110][26], fail[110], end[110];
int root, sz;
int newNode() {
for (int i = 0; i < 26; i++)
nxt[sz][i] = -1;
end[sz++] = 0;
return sz - 1;
}
void init() {
sz = 0;
root = newNode();
}
void insert(char buf[], int id) {
int now = root;
for (int i = 0; buf[i]; i++) {
if (nxt[now][buf[i]-‘a‘] == -1)
nxt[now][buf[i]-‘a‘] = newNode();
now = nxt[now][buf[i]-‘a‘];
}
end[now] |= (1<<id);
}
void build() {
queue<int> q;
fail[root] = root;
for (int i = 0; i < 26; i++) {
if (nxt[root][i] == -1)
nxt[root][i] = root;
else {
fail[nxt[root][i]] = root;
q.push(nxt[root][i]);
}
}
while (!q.empty()) {
int now = q.front();
q.pop();
end[now] |= end[fail[now]];
for (int i = 0; i < 26; i++) {
if (nxt[now][i] == -1)
nxt[now][i] = nxt[fail[now]][i];
else {
fail[nxt[now][i]] = nxt[fail[now]][i];
q.push(nxt[now][i]);
}
}
}
}
int solve() {
for (int i = 0; i <= n; i++)
for (int j = 0; j < sz; j++)
for (int k = 0; k < (1<<m); k++)
dp[i][j][k] = 0;
dp[0][0][0] = 1;
for (int i = 0; i < n; i++)
for (int j = 0; j < sz; j++)
for (int k = 0; k < (1<<m); k++)
if (dp[i][j][k] > 0) {
for (int x = 0; x < 26; x++) {
int ni = i+1;
int nj = nxt[j][x];
int nk = k | end[nj];
dp[ni][nj][nk] += dp[i][j][k];
dp[ni][nj][nk] %= mod;
}
}
int ans = 0;
for (int p = 0; p < (1<<m); p++) {
if (num[p] < k) continue;
for (int i = 0; i < sz; i++)
ans = (ans + dp[n][i][p]) % mod;
}
return ans;
}
} ac;
char buf[20];
int main() {
for (int i = 0; i < (1<<10); i++) {
num[i] = 0;
for (int j = 0; j < 10; j++)
if (i & (1<<j))
num[i]++;
}
while (scanf("%d%d%d", &n, &m, &k) != EOF && n+m+k) {
ac.init();
for (int i = 0; i < m; i++) {
scanf("%s", buf);
ac.insert(buf, i);
}
ac.build();
printf("%d\n", ac.solve());
}
return 0;
}
HDU - 2825 Wireless Password(AC自动机+DP)
声明:以上内容来自用户投稿及互联网公开渠道收集整理发布,本网站不拥有所有权,未作人工编辑处理,也不承担相关法律责任,若内容有误或涉及侵权可进行投诉: 投诉/举报 工作人员会在5个工作日内联系你,一经查实,本站将立刻删除涉嫌侵权内容。