首页 > 代码库 > [tarjan+最小树形图] hdu 3072 Intelligence System

[tarjan+最小树形图] hdu 3072 Intelligence System

题目链接:

http://acm.hdu.edu.cn/showproblem.php?pid=3072

Intelligence System

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1479    Accepted Submission(s): 653


Problem Description
After a day, ALPCs finally complete their ultimate intelligence system, the purpose of it is of course for ACM ... ... 
Now, kzc_tc, the head of the Intelligence Department (his code is once 48, but now 0), is sudden obtaining important information from one Intelligence personnel. That relates to the strategic direction and future development of the situation of ALPC. So it need for emergency notification to all Intelligence personnel, he decides to use the intelligence system (kzc_tc inform one, and the one inform other one or more, and so on. Finally the information is known to all).
We know this is a dangerous work. Each transmission of the information can only be made through a fixed approach, from a fixed person to another fixed, and cannot be exchanged, but between two persons may have more than one way for transferring. Each act of the transmission cost Ci (1 <= Ci <= 100000), the total cost of the transmission if inform some ones in our ALPC intelligence agency is their costs sum. 
Something good, if two people can inform each other, directly or indirectly through someone else, then they belong to the same branch (kzc_tc is in one branch, too!). This case, it’s very easy to inform each other, so that the cost between persons in the same branch will be ignored. The number of branch in intelligence agency is no more than one hundred.
As a result of the current tensions of ALPC’s funds, kzc_tc now has all relationships in his Intelligence system, and he want to write a program to achieve the minimum cost to ensure that everyone knows this intelligence.
It‘s really annoying!
 

Input
There are several test cases. 
In each case, the first line is an Integer N (0< N <= 50000), the number of the intelligence personnel including kzc_tc. Their code is numbered from 0 to N-1. And then M (0<= M <= 100000), the number of the transmission approach.
The next M lines, each line contains three integers, X, Y and C means person X transfer information to person Y cost C. 
 

Output
The minimum total cost for inform everyone.
Believe kzc_tc’s working! There always is a way for him to communicate with all other intelligence personnel.
 

Sample Input
3 3 0 1 100 1 2 50 0 2 100 3 3 0 1 100 1 2 50 2 1 100 2 2 0 1 50 0 1 100
 

Sample Output
150 100 50
 

Source
2009 Multi-University Training Contest 17 - Host by NUDT
 

Recommend
lcy   |   We have carefully selected several similar problems for you:  3069 3077 3070 3071 3073 
 

Statistic | Submit | Discuss | Note
题目意思:

有n个人,告诉前者给后者传送信息的花费,如果两个人能互相传送信息,则这两个人传送信息免费。leader的编号为0.求leader的信息传到所有人的最小花费。

解题思路:

tarjan+最小树形图

先tarjan求强连通分量,然后缩点建图(题目保证是一棵树),然后求最小树形图(做法:把指向所有点的花费最小的边求和即可)

代码:

//#include<CSpreadSheet.h>

#include<iostream>
#include<cmath>
#include<cstdio>
#include<sstream>
#include<cstdlib>
#include<string>
#include<string.h>
#include<cstring>
#include<algorithm>
#include<vector>
#include<map>
#include<set>
#include<stack>
#include<list>
#include<queue>
#include<ctime>
#include<bitset>
#include<cmath>
#define eps 1e-6
#define INF 0x3f3f3f3f
#define PI acos(-1.0)
#define ll __int64
#define LL long long
#define lson l,m,(rt<<1)
#define rson m+1,r,(rt<<1)|1
#define M 1000000007
//#pragma comment(linker, "/STACK:1024000000,1024000000")
using namespace std;

#define Maxn 55000

int low[Maxn],dfn[Maxn],sta[Maxn],sc,bc,n,m,dep;
int in[Maxn],ans;
bool iss[Maxn];
bool vis[110];
vector<vector<int> >myv;
int edge[110][110];
int ex[2*Maxn],ey[2*Maxn],ev[2*Maxn];

void tarjan(int cur)
{
    int ne;

    low[cur]=dfn[cur]=++dep;
    sta[++sc]=cur;
    iss[cur]=true;

    for(int i=0;i<myv[cur].size();i++)
    {
        int ne=myv[cur][i];
        if(!dfn[ne])
        {
            tarjan(ne);
            if(low[ne]<low[cur])
                low[cur]=low[ne];
        }
        else if(iss[ne]&&dfn[ne]<low[cur])
            low[cur]=dfn[ne];
    }
    if(low[cur]==dfn[cur])
    {
        ++bc;
        do
        {
            ne=sta[sc--];
            iss[ne]=false;
            in[ne]=bc;
        }while(ne!=cur);
    }
}
void solve()
{
    dep=sc=bc=0;
    memset(iss,false,sizeof(iss));
    memset(dfn,0,sizeof(dfn));

    for(int i=0;i<n;i++)
        if(!dfn[i])
            tarjan(i);
}


int main()
{
    //freopen("in.txt","r",stdin);
   //freopen("out.txt","w",stdout);
   while(~scanf("%d%d",&n,&m))
   {
       myv.clear();
       myv.resize(n+1);

       for(int i=1;i<=m;i++)
       {
           scanf("%d%d%d",&ex[i],&ey[i],&ev[i]);
           myv[ex[i]].push_back(ey[i]);
       }
       solve();
       memset(edge,INF,sizeof(edge));
       for(int i=1;i<=m;i++)
       {
           int a=ex[i],b=ey[i];

           if(in[a]!=in[b])
               edge[in[a]][in[b]]=min(edge[in[a]][in[b]],ev[i]);
       }
       memset(vis,false,sizeof(vis));
       vis[in[0]]=true;
       int ans=0;

       for(int i=1;i<bc;i++)
       {
           int temp=INF,re;

           for(int j=1;j<=bc;j++)
                for(int k=1;k<=bc;k++)
                {
                    if(!vis[k]&&edge[j][k]<temp)
                    {
                        temp=edge[j][k];
                        re=k;
                    }
                }
           ans+=temp;
           vis[re]=true;
       }
       printf("%d\n",ans);

   }
    return 0;
}


[tarjan+最小树形图] hdu 3072 Intelligence System