首页 > 代码库 > POJ3164 Command Network 【最小树形图】

POJ3164 Command Network 【最小树形图】

Command Network
Time Limit: 1000MS Memory Limit: 131072K
Total Submissions: 12648 Accepted: 3656

Description

After a long lasting war on words, a war on arms finally breaks out between littleken’s and KnuthOcean’s kingdoms. A sudden and violent assault by KnuthOcean’s force has rendered a total failure of littleken’s command network. A provisional network must be built immediately. littleken orders snoopy to take charge of the project.

With the situation studied to every detail, snoopy believes that the most urgent point is to enable littenken’s commands to reach every disconnected node in the destroyed network and decides on a plan to build a unidirectional communication network. The nodes are distributed on a plane. If littleken’s commands are to be able to be delivered directly from a node A to another node B, a wire will have to be built along the straight line segment connecting the two nodes. Since it’s in wartime, not between all pairs of nodes can wires be built. snoopy wants the plan to require the shortest total length of wires so that the construction can be done very soon.

Input

The input contains several test cases. Each test case starts with a line containing two integer N (N ≤ 100), the number of nodes in the destroyed network, and M (M ≤ 104), the number of pairs of nodes between which a wire can be built. The next N lines each contain an ordered pair xi and yi, giving the Cartesian coordinates of the nodes. Then follow M lines each containing two integers i and j between 1 and N (inclusive) meaning a wire can be built between node i and node j for unidirectional command delivery from the former to the latter. littleken’s headquarter is always located at node 1. Process to end of file.

Output

For each test case, output exactly one line containing the shortest total length of wires to two digits past the decimal point. In the cases that such a network does not exist, just output ‘poor snoopy’.

Sample Input

4 6
0 6
4 6
0 0
7 20
1 2
1 3
2 3
3 4
3 1
3 2
4 3
0 0
1 0
0 1
1 2
1 3
4 1
2 3

Sample Output

31.19
poor snoopy
POJ真奇怪,这题用G++提交WA,用C++就AC了。

题意:给定n个顶点和m条有向边,求最小树形图。

题解:这题是最小树形图的模板题了,大致总结一下最小树形图的朱刘算法:

1、求最短弧集,对于除了根之外的每个节点,找出它的最短入边,放入in[]数组,然后判断是否有除根外的顶点没有入边即是否有孤立点,若有则不存在最小树形图;

2、将每个顶点的最短入边权值加入ans中,检查有向回路,若没有回路则当前ans即为最小树形图的权值,算法结束,否则将有向回路缩成一个点并重新构图,每个点的编号要重新哈希,对应边的权值若不在环中要减去入点的的最短入边值,因为之前已经将它加入ans中,重复步骤一直到无环为止。

#include <stdio.h>
#include <string.h>
#include <math.h>
#include <limits.h>
#define maxn 102
#define maxm 10002
#define inf INT_MAX

struct Node{
	double x, y;
} ver[maxn];
struct Node2{
	int u, v;
	double cost;
} edge[maxm];
double ans;
int pre[maxn], hash[maxn], vis[maxn];
double in[maxn];

bool ZL_MST(int root, int nv, int ne)
{
	ans = 0;
	int i, u, v, cntnode;
	while(true){
		for(i = 0; i < nv; ++i) in[i] = inf;
		for(i = 0; i < ne; ++i){
			u = edge[i].u; v = edge[i].v;
			if(edge[i].cost < in[v] && u != v){
				pre[v] = u; in[v] = edge[i].cost;
			}
		}
		for(i = 0; i < nv; ++i)
			if(i != root && in[i] == inf) return false;
		memset(hash, -1, sizeof(hash));
		memset(vis, -1, sizeof(vis));
		in[root] = cntnode = 0;
		for(i = 0; i < nv; ++i){
			ans += in[i];
			v = i;
			while(vis[v] != i && hash[v] == -1 && v != root){
				vis[v] = i; v = pre[v];
			}
			if(v != root && hash[v] == -1){
				for(u = pre[v]; u != v; u = pre[u]){
					hash[u] = cntnode;
				}
				hash[v] = cntnode++;
			}
		}
		if(cntnode == 0) break;
		for(i = 0; i < nv; ++i)
			if(hash[i] == -1) hash[i] = cntnode++;

		for(i = 0; i < ne; ++i){
			v = edge[i].v;
			edge[i].u = hash[edge[i].u];
			edge[i].v = hash[edge[i].v];
			if(edge[i].u != edge[i].v){
				edge[i].cost -= in[v];
			}
		}

		nv = cntnode;
		root = hash[root];
	}
	return true;
}

int main()
{
	int n, m, a, b, i;
	double x, y;
	while(scanf("%d%d", &n, &m) == 2){
		for(i = 0; i < n; ++i)
			scanf("%lf%lf", &ver[i].x, &ver[i].y);
		for(i = 0; i < m; ++i){
			scanf("%d%d", &a, &b);
			x = ver[--a].x - ver[--b].x;
			y = ver[a].y - ver[b].y;
			edge[i].cost = sqrt(x * x + y * y);
			edge[i].u = a; edge[i].v = b;
		}
		if(ZL_MST(0, n, m)) printf("%.2lf\n", ans);
		else printf("poor snoopy\n");
	}
	return 0;
}