首页 > 代码库 > HDU 1102 && POJ 2421 Constructing Roads (经典MST~Prim)

HDU 1102 && POJ 2421 Constructing Roads (经典MST~Prim)

链接:http://poj.org/problem?id=2421  或   http://acm.hdu.edu.cn/showproblem.php?pid=1102

Problem Description
There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each other. We say two village A and B are connected, if and only if there is a road between A and B, or there exists a village C such that there is a road between A and C, and C and B are connected. 

We know that there are already some roads between some villages and your job is the build some roads such that all the villages are connect and the length of all the roads built is minimum.
 
Input
The first line is an integer N (3 <= N <= 100), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 1000]) between village i and village j.

Then there is an integer Q (0 <= Q <= N * (N + 1) / 2). Then come Q lines, each line contains two integers a and b (1 <= a < b <= N), which means the road between village a and village b has been built.
 
Output
You should output a line contains an integer, which is the length of all the roads to be built such that all the villages are connected, and this value is minimum. 
 
Sample Input
3 0 990 692 990 0 179 692 179 0 1 1 2
 
Sample Output
179
 
分析: 将已经修好的街道间的花费设为0, 然后使用Prim算法求解最小生成树;

代码:
#include <iostream>
#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <queue>
#define MAXN 10005
#define INF 0x1f1f1f1f
#define RST(N)memset(N, 0, sizeof(N))
using namespace std;

int n, m, res, u, v, w;
int low[MAXN], vis[MAXN], Edge[205][205];
/low表示每个点到生成树的最小距离,vis表示一个点是否已加入生成树中,Edge表示图的邻接矩阵;
void Init()
{
    RST(low), RST(vis), res = 0;
    for(int i=0; i<n; i++) {
        for(int j=0; j<n; j++) {
            scanf("%d", &Edge[i][j]);
        }
    }
    scanf("%d", &m);
    for(int i=0; i<m; i++) {
        scanf("%d %d", &u, &v);
        Edge[u-1][v-1] = Edge[v-1][u-1] = 0;
    }
}

int Prim()
{
    vis[0] = 1;
    for(int i=1; i<n; i++) low[i] = Edge[0][i];
    for(int i=1; i<n; i++) {
        int min = INF, p = -1;
        for(int j=0; j<n; j++) {
            if(!vis[j] && low[j] < min) {
                min = low[j];
                p = j;
            }
        }
        if(min == INF) return -1; //说明找不到能够加入的点了,说明图是不连通的;
        res += min;
        vis[p] = 1;
        for(int j=0; j<n; j++) {
            if(!vis[j] && low[j] > Edge[p][j]) low[j] = Edge[p][j];
        }
    }
    return res;
}

int main()
{
    while(~scanf("%d", &n)) {
        Init();
        printf("%d\n", Prim());
    }
    return 0;
}