首页 > 代码库 > HDU 1032 The 3n + 1 problem【递归】

HDU 1032 The 3n + 1 problem【递归】

/*
中文题目 3n+1问题
中文翻译-大意 当一个数n是奇数的时候变成3*n+1,为偶数的时候变成n/2
解题思路:区间内每个数逐个求解
难点详解:如何逐个计算每个数的次数,选用while循环,还有就是将此时的 i 值赋给data,用于while循环的条件。最后再将这一个数运算次数累加在一起
关键点:理解题意
解题人:lingnichong
解题时间:2014-06-03 09:40:39
解题体会:没有告诉你那个大那个小,要先比较一下数,是个陷阱
*/


The 3n + 1 problem

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 22664    Accepted Submission(s): 8492


Problem Description
Problems in Computer Science are often classified as belonging to a certain class of problems (e.g., NP, Unsolvable, Recursive). In this problem you will be analyzing a property of an algorithm whose classification is not known for all possible inputs.

Consider the following algorithm: 


    1.      input n

    2.      print n

    3.      if n = 1 then STOP

    4.           if n is odd then n <- 3n + 1

    5.           else n <- n / 2

    6.      GOTO 2


Given the input 22, the following sequence of numbers will be printed 22 11 34 17 52 26 13 40 20 10 5 16 8 4 2 1 

It is conjectured that the algorithm above will terminate (when a 1 is printed) for any integral input value. Despite the simplicity of the algorithm, it is unknown whether this conjecture is true. It has been verified, however, for all integers n such that 0 < n < 1,000,000 (and, in fact, for many more numbers than this.) 

Given an input n, it is possible to determine the number of numbers printed (including the 1). For a given n this is called the cycle-length of n. In the example above, the cycle length of 22 is 16. 

For any two numbers i and j you are to determine the maximum cycle length over all numbers between i and j. 
 

Input
The input will consist of a series of pairs of integers i and j, one pair of integers per line. All integers will be less than 1,000,000 and greater than 0. 

You should process all pairs of integers and for each pair determine the maximum cycle length over all integers between and including i and j. 

You can assume that no opperation overflows a 32-bit integer.
 

Output
For each pair of input integers i and j you should output i, j, and the maximum cycle length for integers between and including i and j. These three numbers should be separated by at least one space with all three numbers on one line and with one line of output for each line of input. The integers i and j must appear in the output in the same order in which they appeared in the input and should be followed by the maximum cycle length (on the same line). 
 

Sample Input
1 10 100 200 201 210 900 1000
 

Sample Output
1 10 20 100 200 125 201 210 89 900 1000 174
 

Source
UVA
 


#include<stdio.h>  
int main()  
{  
    int a,b,min,max,ans,data,num,i,t;  
    while(scanf("%d%d",&min,&max)!=EOF)  
    { 
        a=min;
        b=max;
        if(min>max)  
        {  
            t=min;min=max;max=t;  //交换min、max的值  
        }  
        ans=0;
        for(i=min;i<=max;i++)  
        {  
            num=1;  
            data=http://www.mamicode.com/i;  >






HDU 1032 The 3n + 1 problem【递归】