首页 > 代码库 > HDU - 4550 卡片游戏

HDU - 4550 卡片游戏

Description

  小明最近宅在家里无聊,于是他发明了一种有趣的游戏,游戏道具是N张叠在一起的卡片,每张卡片上都有一个数字,数字的范围是0~9,游戏规则如下:
  首先取最上方的卡片放到桌子上,然后每次取最上方的卡片,放到桌子上已有卡片序列的最右边或者最左边。当N张卡片全部都放到桌子上后,桌子上的N张卡片构成了一个数。这个数不能有前导0,也就是说最左边的卡片上的数字不能是0。游戏的目标是使这个数最小。
  现在你的任务是帮小明写段程序,求出这个最小数。
 

Input

第一行是一个数T,表示有T组测试数据;
然后下面有T行, 每行是一个只含有0~9的字符串,表示N张叠在一起的卡片,最左边的数字表示最上方的卡片。

[Technical Specification]
T<=1000
1 <= N <= 100
 

Output

对于每组测试数据,请在一行内输出能得到的最小数。
 

Sample Input

3 565 9876543210 9876105432
 

Sample Output

556 1234567890 1678905432

思路:贪心的从后向前开始,大的放后面,然后找到当前最小的,从后面来也可以排除0放到第一个的可能

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int MAXN = 200;

char str[MAXN];
char head[MAXN],tail[MAXN];

int main() {
	int t;
	scanf("%d", &t);
	while (t--) {
		scanf("%s", str);
		int n = strlen(str);
		int a = 0, b = 0;
		int cnt = n-1;
		while (str[cnt] == '0' && cnt > 0)
			cnt--;
		for (int i = cnt; i >= 0; i--) 
			if (str[cnt] > str[i] && str[i] != '0')
				cnt = i;
		head[a++] = str[cnt];
		for (int i = n-1; i > cnt; i--)
			tail[b++] = str[i];
		while (a+b < n && cnt > 0) {
			int tmp = cnt-1;
			for (int j = tmp-1; j >= 0; j--)
				if (str[j] < str[tmp])
					tmp = j;
			head[a++] = str[tmp];
			for (int j = cnt-1; j > tmp; j--)
				tail[b++] = str[j];
			cnt = tmp;
		}
		for (int i = 0; i < a; i++)
			printf("%c", head[i]);
		for (int j = b-1; j >= 0; j--)
			printf("%c", tail[j]);
		printf("\n");
	}
	return 0;
}