首页 > 代码库 > poj3617 Best Cow Line

poj3617 Best Cow Line

转载请注明出处:http://blog.csdn.net/u012860063

题目链接:http://poj.org/problem?id=3617

【题意】

一个长度为N(N<=1000)的字符串,每次可以从队尾或队首拿出一个字符加入到新字符串队尾,求字典序最小的新字符串

【输入】

第一行一个N

接下来N行每行一个大写字母

【输出】

字典序最小的新字符串

Description

FJ is about to take his N (1 ≤ N ≤ 2,000) cows to the annual"Farmer of the Year" competition. In this contest every farmer arranges his cows in a line and herds them past the judges.

The contest organizers adopted a new registration scheme this year: simply register the initial letter of every cow in the order they will appear (i.e., If FJ takes Bessie, Sylvia, and Dora in that order he just registers BSD). After the registration phase ends, every group is judged in increasing lexicographic order according to the string of the initials of the cows‘ names.

FJ is very busy this year and has to hurry back to his farm, so he wants to be judged as early as possible. He decides to rearrange his cows, who have already lined up, before registering them.

FJ marks a location for a new line of the competing cows. He then proceeds to marshal the cows from the old line to the new one by repeatedly sending either the first or last cow in the (remainder of the) original line to the end of the new line. When he‘s finished, FJ takes his cows for registration in this new order.

Given the initial order of his cows, determine the least lexicographic string of initials he can make this way.

Input

* Line 1: A single integer: N
* Lines 2..N+1: Line i+1 contains a single initial (‘A‘..‘Z‘) of the cow in the ith position in the original line

Output

The least lexicographic string he can make. Every line (except perhaps the last one) contains the initials of 80 cows (‘A‘..‘Z‘) in the new line.

Sample Input

6
A
C
D
B
C
B

Sample Output

ABCBCD

Source

USACO 2007 November Silver

代码如下:

#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
using namespace std;
#define PI acos(-1.0)
#define INF 0x3fffffff
int main()
{
	int n;
	char c,a[2047];
	int i,k,j;
	while(~scanf("%d",&n))
	{
		k = 0 ;
		memset(a,0,sizeof(a));
		for(i = 0; i < n; i++)
		{
			getchar();
			scanf("%c",&a[i]);
		}
		int t1=0,t2=n-1;//t1是首部t2是尾部
		for(i = 0; ; i++)
		{
			if(a[t1] < a[t2])
			{
				printf("%c",a[t1]);
				t1++,k++;
			}
			else if(a[t1] > a[t2])
			{
				printf("%c",a[t2]);
				t2--,k++;
			}
			else if(a[t1] == a[t2])//如果首尾的字母是相同的
			{//就接着向中间找,直至找到两个不同的
				int c1 ,c2;
				c1= t1,c2=t2;
				while(a[c1] == a[c2])
				{
					c1++,c2--;
				}
				if(a[c1] < a[c2])
				{
					printf("%c",a[t1]);
					t1++,k++;
				}
				else
				{
					printf("%c",a[t2]);
					t2--,k++;
				}
			}
			if(k%80 == 0)
				printf("\n");
			if(k == n)
				break;
		}
		printf("\n");
	}
	return 0;
}