首页 > 代码库 > [ALGO-49] 寻找数组中最大值

[ALGO-49] 寻找数组中最大值

算法训练 寻找数组中最大值  
时间限制:1.0s   内存限制:512.0MB
问题描述
  对于给定整数数组a[],寻找其中最大值,并返回下标。
输入格式
  整数数组a[],数组元素个数小于1等于100。输出数据分作两行:第一行只有一个数,表示数组元素个数;第二行为数组的各个元素。
输出格式
  输出最大值,及其下标
样例输入
3
3 2 1
样例输出
3 0
说明:蓝桥杯官网上的“样例输入”格式不对,我在这里改成了对的格式

import java.util.Scanner;

public class Main {

	public static void main(String[] args) {
		Scanner scanner = new Scanner(System.in);

		while (scanner.hasNext()) {
			int n = scanner.nextInt();

			int[] arr = new int[n];
			for (int i = 0; i < n; i++) {
				arr[i] = scanner.nextInt();
			}

			int max = Integer.MIN_VALUE;
			int index = -1;

			for (int i = 0; i < n; i++) {
				if (max < arr[i]) {
					max = arr[i];
					index = i;
				}
			}

			System.out.println(max + " " + index);
		}
	}
}