首页 > 代码库 > HDU3427 Clickomania 【DP】

HDU3427 Clickomania 【DP】

Clickomania

Time Limit: 20000/10000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 367    Accepted Submission(s): 193


Problem Description
Clickomania is a puzzle in which one starts with a rectangular grid of cells of different colours. In each step, a player selects ("clicks") a cell. All connected cells of the same colour as the selected cell (including itself) are removed if the selected cell is connected to at least one other cell of the same colour. The resulting "hole" is filled in by adjacent cells based on some rule, and the object of the game is to remove all cells in the grid. In this problem, we are interested in the one-dimensional version of the problem. The starting point of the puzzle is a string of colours (each represented by an uppercase letter).
At any point, one may select (click) a letter provided that the same letter occurs before or after the one selected. The substring of the same letter containing the selected letter is removed, and the string is shortened to remove the hole created. To solve the puzzle, the player has to remove all letters and obtain the empty string. If the player obtains a non-empty string in which no letter can be selected, then the player loses. For example, if one starts with the string "ABBAABBAAB", selecting the first "B" gives "AAABBAAB". Next, selecting the last "A" gives "AAABBB". Selecting an "A" followed by a "B" gives the empty string. On the other hand, if one selects the third "B" first, the string "ABBAAAAB" is obtained. One may verify that regardless of the next selections, we obtain either the string "A" or the string "B" in which no letter can be selected. Thus, one must be careful in the sequence of selections chosen in order to solve a puzzle. Furthermore,
there are some puzzles that cannot be solved regardless of the choice of selections. For example, "ABBAAAAB" is not a solvable puzzle. Some facts are known about solvable puzzles: The empty string is solvable. If x and y are solvable puzzles, so are xy, AxA, and AxAyA for any uppercase letter
A. All other puzzles not covered by the rules above are unsolvable.
Given a puzzle, your task is to determine whether it can be solved or not.
 

Input
Each case of input is specified by a single line. Each line contains a string of uppercase letters. Each string has at least one but no more than 150 characters. The input is terminated by the end of file.
 

Output
For each input case, print solvable on a single line if there is a sequence of selections that solves the puzzle. Otherwise, print unsolvable on a line.
 

Sample Input
ABBAABBAAB ABBAAAAB
 

Sample Output
solvable unsolvable

题意:字符串“消消看”,只有当两个或以上相同的字符串挨着时才能被消掉。

题解:题目已经把所有的合法情况都列出来了,即xy,AxA,AxAyA...剩下的就用记忆化搜索来解决。

#include <stdio.h>
#include <string.h>

#define maxn 152
#define YES dp[L][R] = 1
#define NO dp[L][R] = -1, false

int dp[maxn][maxn];
char str[maxn];

bool Judge(int L, int R) {
	if (L == R) return false;	
	if (L > R) return true;
	if (dp[L][R] == 1) return true;
	if (dp[L][R] == -1) return false;

	int i;
	for (i = L + 1; i < R - 1; ++i) // xy
		if (Judge(L, i) && Judge(i + 1, R)) {
			return YES;
		}
	if (str[L] == str[R]) {
		if (Judge(L + 1, R - 1)) return YES; // AxA
		for (i = L + 1; i < R; ++i)
			if (str[i] == str[L] && Judge(L + 1, i - 1) && Judge(i + 1, R - 1)) // AxAyA
				return YES;
	}
	return NO;
}

int main() {
	freopen("stdin.txt", "r", stdin);
	while (scanf("%s", str) == 1) {
		memset(dp, 0, sizeof(dp));
		if (!Judge(0, strlen(str) - 1)) printf("un");
		puts("solvable");
	}
	return 0;
}


HDU3427 Clickomania 【DP】