首页 > 代码库 > ZOJ 2987 Misspelling(模拟)

ZOJ 2987 Misspelling(模拟)

题目链接:http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemId=1986


Misspelling is an art form that students seem to excel at. Write a program that removes thenth character from an input string.

Input

The first line of input contains a single integer N, (1 <= N <= 1000) which is the number of datasets that follow.

Each dataset consists of a single line of input containing M, a space, and a single word made up of uppercase letters only.M will be less than or equal to the length of the word. The length of the word is guaranteed to be less than or equal to 80.

Output

For each dataset, you should generate one line of output with the following values: The dataset number as a decimal integer (start counting at one), a space, and the misspelled word. The misspelled word is the input word with the indicated character deleted.

Sample Input

4
4 MISSPELL
1 PROGRAMMING
7 CONTEST
3 BALLOON

Sample Output

1 MISPELL
2 ROGRAMMING
3 CONTES
4 BALOON


代码如下:

#include <cstdio>
#include <cstring>
int main()
{
    int k = 0, n;
    int t;
    char s[1117];
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d %s",&n,s);
        k++;
        printf("%d ",k);
        int len = strlen(s);
        for(int i = 0; i < len; i++)
        {
            if(i != n-1)
            {
                printf("%c",s[i]);
            }
        }
        printf("\n");
    }
    return 0;
}


ZOJ 2987 Misspelling(模拟)