首页 > 代码库 > 建造道路 (Building Roads, USACO 2007 Dec)

建造道路 (Building Roads, USACO 2007 Dec)

题目描述

Farmer John had just acquired several new farms! He wants to connect the farms with roads so that he can travel from any farm to any other farm via a sequence of roads; roads already connect some of the farms.

Each of the N (1 ≤ N ≤ 1,000) farms (conveniently numbered 1..N) is represented by a position (Xi, Yi) on the plane (0 ≤ Xi ≤ 1,000,000; 0 ≤ Yi ≤ 1,000,000). Given the preexisting M roads (1 ≤ M ≤ 1,000) as pairs of connected farms, help Farmer John determine the smallest length of additional roads he must build to connect all his farms.

给出nn个点的坐标,其中一些点已经连通,现在要把所有点连通,求修路的最小长度.

输入输出格式

输入格式:

 

  • Line 1: Two space-separated integers: N and M

  • Lines 2..N+1: Two space-separated integers: Xi and Yi

  • Lines N+2..N+M+2: Two space-separated integers: i and j, indicating that there is already a road connecting the farm i and farm j.

 

输出格式:

 

  • Line 1: Smallest length of additional roads required to connect all farms, printed without rounding to two decimal places. Be sure to calculate distances as 64-bit floating point numbers.

 

输入输出样例

输入样例#1:
4 1
1 1
3 1
2 3
4 3
1 4
输出样例#1:
4.00








一道kruskal裸题

注意精度问题,算两点间距离时要强制转换double类型





#include<iostream>
#include<cstdio>
#include<cmath>
#include<algorithm>
using namespace std;
struct pos
{
    int x,y;
}a[1050];
double dis(pos a,pos b)
{
    return sqrt((double)(a.x-b.x)*(double)(a.x-b.x)+(double)(a.y-b.y)*(double)(a.y-b.y));
}
struct Edge
{
    int u,v;
    double w;
    friend bool operator <(Edge a,Edge b){return a.w<b.w;}
}e[1000050];
int father[1050];
int Find(int x)
{
    if(father[x]==x) return x;
    return father[x]=Find(father[x]);
}
int main()
{
    int n,m;
    scanf("%d%d",&n,&m);
    for(int i=1;i<=n;i++)
        scanf("%d%d",&a[i].x,&a[i].y);
    for(int i=1;i<=n;i++)
        father[i]=i;
    for(int i=1;i<=m;i++)
    {
        int x,y;
        scanf("%d%d",&x,&y);
        x=Find(x),y=Find(y);
        father[x]=y;
    }
    int tot=0;
    for(int i=1;i<=n;i++)
        for(int j=i;j<=n;j++)
            {
                tot++;
                e[tot].u=i;
                e[tot].v=j;
                e[tot].w=dis(a[i],a[j]);
            }
    sort(e+1,e+tot+1);
    double ans=0;
    int sum=0;
    for(int i=1;i<=tot;i++)
    {
        int u=Find(e[i].u),v=Find(e[i].v);
        if(u!=v)
        {
            father[u]=v;
            ans+=e[i].w;
            sum++;
        }
    }
    printf("%.2lf",ans);

}

 

 

建造道路 (Building Roads, USACO 2007 Dec)