首页 > 代码库 > HDU-1222
HDU-1222
http://acm.hdu.edu.cn/status.php?first=&pid=&user=sunowsir&lang=0&status=0
题目描述:
There is a hill with n holes around. The holes are signed from 0 to n-1.
A rabbit must hide in one of the holes. A wolf searches the rabbit in anticlockwise order. The first hole he get into is the one signed with 0. Then he will get into the hole every m holes. For example, m=2 and n=6, the wolf will get into the holes which are signed 0,2,4,0. If the rabbit hides in the hole which signed 1,3 or 5, she will survive. So we call these holes the safe holes.
A rabbit must hide in one of the holes. A wolf searches the rabbit in anticlockwise order. The first hole he get into is the one signed with 0. Then he will get into the hole every m holes. For example, m=2 and n=6, the wolf will get into the holes which are signed 0,2,4,0. If the rabbit hides in the hole which signed 1,3 or 5, she will survive. So we call these holes the safe holes.
InputThe input starts with a positive integer P which indicates the number of test cases. Then on the following P lines,each line consists 2 positive integer m and n(0<m,n<2147483648).
OutputFor each input m n, if safe holes exist, you should output "YES", else output "NO" in a single line.
Sample Input
2 1 2 2 2Sample Output
NO YES
题目思路:
只需要判断m和n的最大公约数是否等于1即可,不等于一则永远抓不到;
代码:
/*************************************************************************
> File Name: HDU-1222.cpp
> Author: sunowsir
************************************************************************/
#include<bits/stdc++.h>
using namespace std;
int gcd(int a,int b){
return b==0? a:gcd(b , a%b);
}
int main(){
int m,n,N;
cin>>N;
while(N--){
cin>>m>>n;
if(gcd(m,n)!=1) cout<<"YES"<<endl;
else cout<<"NO"<<endl;
}
return 0;
}
HDU-1222
声明:以上内容来自用户投稿及互联网公开渠道收集整理发布,本网站不拥有所有权,未作人工编辑处理,也不承担相关法律责任,若内容有误或涉及侵权可进行投诉: 投诉/举报 工作人员会在5个工作日内联系你,一经查实,本站将立刻删除涉嫌侵权内容。