首页 > 代码库 > hdoj 4841 圆桌问题 【模拟】

hdoj 4841 圆桌问题 【模拟】

圆桌问题

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)
Total Submission(s): 299    Accepted Submission(s): 107


Problem Description
圆桌上围坐着2n个人。其中n个人是好人,另外n个人是坏人。如果从第一个人开始数数,数到第m个人,则立即处死该人;然后从被处死的人之后开始数数,再将数到的第m个人处死……依此方法不断处死围坐在圆桌上的人。试问预先应如何安排这些好人与坏人的座位,能使得在处死n个人之后,圆桌上围坐的剩余的n个人全是好人。
 

Input
多组数据,每组数据输入:好人和坏人的人数n(<=32767)、步长m(<=32767);
 

Output
对于每一组数据,输出2n个大写字母,‘G’表示好人,‘B’表示坏人,50个字母为一行,不允许出现空白字符。相邻数据间留有一空行。
 

Sample Input
2 3 2 4
 

Sample Output
GBBG BGGB

注意换行。。。

代码:

#include <cstdio>
#include <cstring>
const int M = 33000;

int s[M<<1];

void f(int n, int m){
    int t, i, j;
    j = 0;
    for(i = 0; i < n; i ++){
        int cou = 0;
        while(cou < m){
            if(s[j] == 0) ++cou;
            if(cou >= m) break;
            j ++;
            if(j == 2*n) j = 0;

        }
        s[j] = 1;
    }
}

int main(){
   int n, m;
    while(scanf("%d%d", &n, &m) == 2){
        memset(s, 0, sizeof(s));
        f(n, m);
        int i;
        for(i = 0; i < 2*n; i ++){
            if(i&&i%50 == 0) printf("\n");
            printf("%c", s[i]?'B':'G');
        }
        printf("\n\n");
    }
    return 0;
}


hdoj 4841 圆桌问题 【模拟】