首页 > 代码库 > hdu 1098 典型的数学题嘛
hdu 1098 典型的数学题嘛
Ignatius‘s puzzle
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 6683 Accepted Submission(s): 4625
Problem Description
Ignatius is poor at math,he falls across a puzzle problem,so he has no choice but to appeal to Eddy. this problem describes that:f(x)=5*x^13+13*x^5+k*a*x,input a nonegative integer k(k<10000),to find the minimal nonegative integer a,make the arbitrary integer x ,65|f(x)if no exists that a,then print "no".
Input
The input contains several test cases. Each test case consists of a nonegative integer k, More details in the Sample Input.
Output
The output contains a string "no",if you can‘t find a,or you should output a line contains the a.More details in the Sample Output.
Sample Input
11
100
9999
Sample Output
22
no
43
ps:有些取巧,当满足x=1时,取能最小的a能被65整除
详细证明:http://www.cnblogs.com/g0feng/archive/2012/08/23/2652996.html
#include "stdio.h"
int main()
{
int k,a;
while(~scanf("%d",&k))
{
for(a=1;a<=65;a++) //65一个循环,所以到65就行。。
if((18+a*k)%65==0)
{
printf("%d\n",a);
break;
}
if(a==66)
printf("no\n");
}
return 0;
}
int main()
{
int k,a;
while(~scanf("%d",&k))
{
for(a=1;a<=65;a++) //65一个循环,所以到65就行。。
if((18+a*k)%65==0)
{
printf("%d\n",a);
break;
}
if(a==66)
printf("no\n");
}
return 0;
}
hdu 1098 典型的数学题嘛
声明:以上内容来自用户投稿及互联网公开渠道收集整理发布,本网站不拥有所有权,未作人工编辑处理,也不承担相关法律责任,若内容有误或涉及侵权可进行投诉: 投诉/举报 工作人员会在5个工作日内联系你,一经查实,本站将立刻删除涉嫌侵权内容。