首页 > 代码库 > POJ 3176(Cow Bowling )(就是简单的数塔,动态规划)

POJ 3176(Cow Bowling )(就是简单的数塔,动态规划)

Cow Bowling
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 14206 Accepted: 9428

Description

The cows don‘t use actual bowling balls when they go bowling. They each take a number (in the range 0..99), though, and line up in a standard bowling-pin-like triangle like this: 

          7



        3   8



      8   1   0



    2   7   4   4



  4   5   2   6   5
Then the other cows traverse the triangle starting from its tip and moving "down" to one of the two diagonally adjacent cows until the "bottom" row is reached. The cow‘s score is the sum of the numbers of the cows visited along the way. The cow with the highest score wins that frame. 

Given a triangle with N (1 <= N <= 350) rows, determine the highest possible sum achievable.

Input

Line 1: A single integer, N 

Lines 2..N+1: Line i+1 contains i space-separated integers that represent row i of the triangle.

Output

Line 1: The largest sum achievable using the traversal rules

Sample Input

5
7
3 8
8 1 0
2 7 4 4
4 5 2 6 5

Sample Output

30

Hint

Explanation of the sample: 

          7

         *

        3   8

       *

      8   1   0

       *

    2   7   4   4

       *

  4   5   2   6   5
The highest score is achievable by traversing the cows as shown above.

Source

USACO 2005 December Bronze

题意
求出所有数中的最大值,就是简单的数塔问题!
代码如下:
#include<stdio.h>
#include<algorithm>
using namespace std;
int a[444][444];
int main()
{
	int n,i,j;
	while(~scanf("%d",&n))
	{
		for(i=1;i<=n;i++)
		{
			for(j=1;j<=i;j++)
			{
				scanf("%d",&a[i][j]);
			}
		}
		for(i=n-1;i>0;i--)//比较的时候与正下方的还有左侧的进行比较!从下往上进行规划。
		{
			for(j=1;j<=i;j++)//等于别忘了, 因为是从倒数第二行开始的,所以开始的时候,还是可以去到i的。
			{
				a[i][j]+=max(a[i+1][j],a[i+1][j+1]); 
			}
		}
		printf("%d\n",a[1][1]);
	}
	return 0;
}


POJ 3176(Cow Bowling )(就是简单的数塔,动态规划)