首页 > 代码库 > poj 3122 Pie (二分)

poj 3122 Pie (二分)

<span style="background-color: rgb(255, 255, 255); font-family: Arial, Helvetica, sans-serif; font-size: 18pt;">Description</span>
My birthday is coming up and traditionally I‘m serving pie. Not just one pie, no, I have a number N of them, of various tastes and of various sizes. F of my friends are coming to my party and each of them gets a piece of pie. This should be one piece of one pie, not several small pieces since that looks messy. This piece can be one whole pie though. 

My friends are very annoying and if one of them gets a bigger piece than the others, they start complaining. Therefore all of them should get equally sized (but not necessarily equally shaped) pieces, even if this leads to some pie getting spoiled (which is better than spoiling the party). Of course, I want a piece of pie for myself too, and that piece should also be of the same size. 

What is the largest possible piece size all of us can get? All the pies are cylindrical in shape and they all have the same height 1, but the radii of the pies can be different.

Input

One line with a positive integer: the number of test cases. Then for each test case:
  • One line with two integers N and F with 1 ≤ N, F ≤ 10 000: the number of pies and the number of friends.
  • One line with N integers ri with 1 ≤ ri ≤ 10 000: the radii of the pies.

Output

For each test case, output one line with the largest possible volume V such that me and my friends can all get a pie piece of size V. The answer should be given as a floating point number with an absolute error of at most 10?3.

Sample Input

3
3 3
4 3 3
1 24
5
10 5
1 4 2 3 4 5 6 5 4 2

Sample Output

25.1327
3.1416
50.2655

Source

Northwestern Europe 2006

题意:给出若干个pie的半径,从这些pie中切出m个大小相等形状任意的块。可以剩余边角余料并扔掉。问每块最大多大。

分析:这题是浮点数的二分题,二分每块的大小。


CODE:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<string>
#include<algorithm>
#include<cstdlib>
#include<set>
#include<queue>
#include<stack>
#include<vector>
#include<map>

#define N 100010
#define Mod 10000007
#define lson l,mid,idx<<1
#define rson mid+1,r,idx<<1|1
#define lc idx<<1
#define rc idx<<1|1
const double EPS = 1e-11;
const double PI = acos ( -1.0 );
const double E = 2.718281828;
typedef long long ll;

const int INF = 1000010;

using namespace std;

double r[10010];
int n, f;

bool C ( double x )
{
    int num = 0;
    for ( int i = 0; i < n; i++ )
        num += ( int ) ( r[i] / x );
    return num >= f;
}
int main()
{
    int t;
    scanf ( "%d", &t );
    while ( t-- )
    {
        scanf ( "%d%d", &n, &f );
        f++;
        for ( int i = 0; i < n; i++ )
        {
            scanf ( "%lf", &r[i] );
            r[i] = PI * r[i] * r[i];
        }
        double lb = 0, ub = 100000000 * PI;
        for ( int i = 0; i < 100; i++ )
        {
            double mid = ( lb + ub ) / 2;
            if ( C ( mid ) )
                lb = mid;
            else
                ub = mid;
        }
        printf ( "%.4f\n", ub );
    }
    return 0;
}



poj 3122 Pie (二分)