首页 > 代码库 > POJ 2406 Power Strings 简单KMP

POJ 2406 Power Strings 简单KMP

Power Strings
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 33389 Accepted: 13869

Description

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).

Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

Output

For each s you should print the largest n such that s = a^n for some string a.

Sample Input

abcd
aaaa
ababab
.

Sample Output

1
4
3

Hint

This problem has huge input, use scanf instead of cin to avoid time limit exceed.




题意:求一个字符串有多少个循环节,如果没有出现循环就输出1


#include <iostream>
#include <stdio.h>
#include <string>
#include <cstring>
#include <algorithm>
#include <cmath>
#define N 1000009
using namespace std;

char a[N];
int n;
int next[N];
//记住一个性质,1到nxet[n]这一串字符和n-next[n]+1到n这一段字符是相匹配的
void getnext()
{
    int i,j;
    i=0;
    j=-1;
    next[0]=-1;

    while(i<n)
    {
        if(j==-1||a[i]==a[j])
        {
            i++;
            j++;
            next[i]=j;
        }
        else
        j=next[j];
    }
}

int main()
{
    while(~scanf("%s",a))
    {
        if(a[0]=='.') break;

        n=strlen(a);
        getnext();

        if(n%(n-next[n])==0)
        cout<<n/(n-next[n])<<endl;
        else
        cout<<1<<endl;

//        for(int i=0;i<=len;i++)
//        cout<<next[i]<<" ";
//        cout<<endl;

//        if(next[len]==0)
//        cout<<1<<endl;
//        else
//        printf("%d\n",next[len]-1);


    }
    return 0;
}




POJ 2406 Power Strings 简单KMP