首页 > 代码库 > POJ3061 Subsequence

POJ3061 Subsequence

Subsequence
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 8843 Accepted: 3506

Description

A sequence of N positive integers (10 < N < 100 000), each of them less than or equal 10000, and a positive integer S (S < 100 000 000) are given. Write a program to find the minimal length of the subsequence of consecutive elements of the sequence, the sum of which is greater than or equal to S.

Input

The first line is the number of test cases. For each test case the program has to read the numbers N and S, separated by an interval, from the first line. The numbers of the sequence are given in the second line of the test case, separated by intervals. The input will finish with the end of file.

Output

For each the case the program has to print the result on separate line of the output file.if no answer, print 0.

Sample Input

2
10 15
5 1 3 5 10 7 4 9 2 8
5 11
1 2 3 4 5

Sample Output

2
3

Source

Southeastern Europe 2006
版本一:79ms C++

#include <stdio.h>
#include <string.h>
#include <algorithm>

#define maxn 100010

int S[maxn], N, K;

int main() {
    int i, T, cnt, tmp;
    scanf("%d", &T);
    while(T--) {
        scanf("%d%d", &N, &K);
        for(i = 0; i < N; ++i) {
            scanf("%d", &S[i]);
            if(i) S[i] += S[i - 1];
        }
        if(S[N - 1] < K) {
            printf("0\n");
            continue;
        }
        cnt = N + 1;
        for(i = 0; i < N && S[i] + K <= S[N - 1]; ++i) {
            tmp = std::lower_bound(S + i, S + N, S[i] + K) - S - i;
            cnt = std::min(cnt, tmp);
        }
        printf("%d\n", cnt);
    }
    return 0;
}

版本二:79ms C++

#include <stdio.h>
#include <string.h>
#include <algorithm>

#define maxn 100010

int S[maxn], N, K;

int main() {
    int i, T, cnt, sum, s, t;
    scanf("%d", &T);
    while(T--) {
        scanf("%d%d", &N, &K);
        for(i = 0; i < N; ++i) 
            scanf("%d", &S[i]);
        cnt = N + 1; 
        sum = s = t = 0;
        for(i = 0; i < N; ++i) {
            sum += S[i];
            while(sum >= K) {
                t = i - s + 1;
                cnt = std::min(cnt, t);
                sum -= S[s++];
            }
        }
        if(cnt > N) cnt = 0;
        printf("%d\n", cnt);
    }
    return 0;
}


POJ3061 Subsequence