首页 > 代码库 > POJ 3061 Subsequence

POJ 3061 Subsequence

Subsequence
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 8128 Accepted: 3141

Description

A sequence of N positive integers (10 < N < 100 000), each of them less than or equal 10000, and a positive integer S (S < 100 000 000) are given. Write a program to find the minimal length of the subsequence of consecutive elements of the sequence, the sum of which is greater than or equal to S.

Input

The first line is the number of test cases. For each test case the program has to read the numbers N and S, separated by an interval, from the first line. The numbers of the sequence are given in the second line of the test case, separated by intervals. The input will finish with the end of file.

Output

For each the case the program has to print the result on separate line of the output file.if no answer, print 0.

Sample Input

2
10 15
5 1 3 5 10 7 4 9 2 8
5 11
1 2 3 4 5

Sample Output

2
3
AC码:
#include<stdio.h>
#include<iostream>
#include<algorithm>
using namespace std;
int a[100000],n,S,sum[100001],t;
void solve()
{
  for(int i = 0;i<n;i++)
  {
          sum[i+1]=sum[i]+a[i];
  }
  if(sum[n]<S)
  {
        printf("0\n");
         return;
  }
  int res = n;
  for(int s = 0;sum[s]+S<=sum[n];s++)
  {
    //利用二分搜索求出t
    int t = lower_bound(sum+s,sum+n,sum[s]+S)-sum;
    res = min(res,t-s); 
  }
  printf("%d\n",res);
}
int main()
{
          cin>>t;
          while(t--)
          {
            cin>>n>>S;
          for(int i=0;i<n;i++)
          scanf("%d",&a[i]);
          solve();
          
          }
          system("pause");
  return 0;
}
注:上面的代码中使用了lower_bound这个STL函数。这个函数从已排好序的序列a中利用二分搜索找出指向满足ai>=k的最小的指针。类似的函数还有upper_bound,这个函数求出的是指向满足ai>k的ai的最小的指针.