首页 > 代码库 > uva 11059 Maximum Product

uva 11059 Maximum Product

Problem D - Maximum Product

Time Limit: 1 second

Given a sequence of integers S = {S1, S2, ..., Sn}, you should determine what is the value of the maximum positive product involving consecutive terms of S. If you cannot find a positive sequence, you should consider 0 as the value of the maximum product.

Input

Each test case starts with 1 ≤ N ≤ 18, the number of elements in a sequence. Each element Si is an integer such that -10 ≤ Si ≤ 10. Next line will have N integers, representing the value of each element in the sequence. There is a blank line after each test case. The input is terminated by end of file (EOF).

Output

For each test case you must print the message: Case #M: The maximum product is P., where M is the number of the test case, starting from 1, and P is the value of the maximum product. After each test case you must print a blank line.

Sample Input

3
2 4 -3

5
2 5 -1 2 -1

Sample Output

Case #1: The maximum product is 8.

Case #2: The maximum product is 20.

水题,求乘积最大的连续子序列,直接暴力,枚举子序列的两个端点



#include<iostream>
#include<cstdio>
#include<algorithm>
using namespace std;
int a[20];
long long sum(int i,int j)
{
    long long s=1;
    for(;i<=j;i++)
        s*=a[i];
    return s;
}
int main()
{
    int i,x=0,n,j;
    long long s,max_;
    while(scanf("%d",&n)!=EOF)
    {
        x++;
        s=1;
        for(i=0;i<n;i++)
            scanf("%d",a+i);
        max_=-15;
        for(i=0;i<n;i++)
        for(j=i;j<n;j++){
            s=sum(i,j);
            if(max_<s) max_=s;
        }
        printf("Case #%d: The maximum product is ",x);
        if(max_<=0)printf("0.\n\n");
        else printf("%lld.\n\n",max_);

    }
    return 0;
}


uva 11059 Maximum Product