首页 > 代码库 > uva133-The Dole Queue

uva133-The Dole Queue

 The Dole Queue 

In a serious attempt to downsize (reduce) the dole queue, The New National Green Labour Rhinoceros Party has decided on the following strategy. Every day all dole applicants will be placed in a large circle, facing inwards. Someone is arbitrarily chosen as number 1, and the rest are numbered counter-clockwise up to N (who will be standing on 1‘s left). Starting from 1 and moving counter-clockwise, one labour official counts off k applicants, while another official starts from N and moves clockwise, counting m applicants. The two who are chosen are then sent off for retraining; if both officials pick the same person she (he) is sent off to become a politician. Each official then starts counting again at the next available person and the process continues until no-one is left. Note that the two victims (sorry, trainees) leave the ring simultaneously, so it is possible for one official to count a person already selected by the other official.

Input

Write a program that will successively read in (in that order) the three numbers (N, k and m; k, m > 0, 0 < N < 20) and determine the order in which the applicants are sent off for retraining. Each set of three numbers will be on a separate line and the end of data will be signalled by three zeroes (0 0 0).

Output

For each triplet, output a single line of numbers specifying the order in which people are chosen. Each number should be in a field of 3 characters. For pairs of numbers list the person chosen by the counter-clockwise official first. Separate successive pairs (or singletons) by commas (but there should not be a trailing comma).

Sample input

10 4 3
0 0 0

Sample output

tex2html_wrap_inline34 4 tex2html_wrap_inline34 8, tex2html_wrap_inline34 9 tex2html_wrap_inline34 5, tex2html_wrap_inline34 3 tex2html_wrap_inline34 1, tex2html_wrap_inline34 2 tex2html_wrap_inline34 6, tex2html_wrap_inline50 10, tex2html_wrap_inline34 7

where tex2html_wrap_inline50 represents a space.


使用一个数组标记圆圈中的人是否已经选走,为了方便计算下一个人的下标,使用从0开始的地址,因此打印编号的时候需要加一。

写完代码提交后老师报runtime error,怎么也没找到错误,后来才发现是程序结束返回了1的原因,真是没想到。

#include <cstdio>
#include <cstdlib>
#include <cstring>
int queue[25];

int main(void){
	int N, k, m;
	int i;

#ifndef ONLINE_JUDGE
	freopen("f:\\infile.txt", "r", stdin);
#endif

	while(scanf("%d%d%d", &N, &k, &m) && (N != 0)){
		memset(queue, 0, sizeof(queue));
		int p1 = 0, p2 = N-1;
		while(1){
			int kTemp = k, mTemp = m;
			while(1){
				if(queue[p1] == 0){
					kTemp--;
					if(kTemp <= 0) break;
				}
				p1 = (p1+1)%N;
			}
			while(1){
				if(queue[p2] == 0){
					mTemp--;
					if(mTemp <= 0) break;
				}
				p2 = (p2-1+N)%N;
			}
			queue[p1] = 1;
			queue[p2] = 1;

			for(i = 0; i < N; i++){
				if(queue[i] == 0) break;
			}

			if(i == N){
				if(p1 == p2){
					printf("%3d\n", p1+1);
					break;
				}
				else{
					printf("%3d%3d\n", p1+1, p2+1);
					break;
				}
			}
			if(p1 == p2){
				printf("%3d,", p1+1);
			}
			else{
				printf("%3d%3d,", p1+1, p2+1);
			}
		}
	}
	return 0;
}