首页 > 代码库 > UVA 133 The Dole Queue

UVA 133 The Dole Queue

昨天做的时候很郁闷的一道题,今天做一做感觉还可以= =

The Dole Queue

In a serious attempt to downsize (reduce) the dole queue, The New National Green Labour Rhinoceros Party has decided on the following strategy. Every day all dole applicants will be placed in a large circle, facing inwards. Someone is arbitrarily chosen as number 1, and the rest are numbered counter-clockwise up to N (who will be standing on 1‘s left). Starting from 1 and moving counter-clockwise, one labour official counts off k applicants, while another official starts from N and moves clockwise, counting m applicants. The two who are chosen are then sent off for retraining; if both officials pick the same person she (he) is sent off to become a politician. Each official then starts counting again at the next available person and the process continues until no-one is left. Note that the two victims (sorry, trainees) leave the ring simultaneously, so it is possible for one official to count a person already selected by the other official.

Input

Write a program that will successively read in (in that order) the three numbers (N, k and m; k, m > 0, 0 < N < 20) and determine the order in which the applicants are sent off for retraining. Each set of three numbers will be on a separate line and the end of data will be signalled by three zeroes (0 0 0).

Output

For each triplet, output a single line of numbers specifying the order in which people are chosen. Each number should be in a field of 3 characters. For pairs of numbers list the person chosen by the counter-clockwise official first. Separate successive pairs (or singletons) by commas (but there should not be a trailing comma).

Sample input

10 4 3
0 0 0

Sample output

tex2html_wrap_inline34 4tex2html_wrap_inline34 8,tex2html_wrap_inline34 9tex2html_wrap_inline34 5,tex2html_wrap_inline34 3tex2html_wrap_inline34 1,tex2html_wrap_inline34 2tex2html_wrap_inline34 6,tex2html_wrap_inline50 10,tex2html_wrap_inline34 7

where tex2html_wrap_inline50 represents a space. 



调试很多遍,一次ac
#include <iostream>
#include <cstring>
#include <stdio.h>
using namespace std;
int main()
{
    int n,k,m;
    while(cin>>n>>k>>m)
	{
		if(n==0&&k==0&&m==0)
			break;
		bool exit[25];
		memset(exit,true,sizeof(exit));
		int left=n;//剩余人数
		int p=0,q=n+1;
		int cnt1,cnt2;
		while(left!=0)
		{
			cnt1=k;
			while(cnt1--)
			{
				if(p==n)
					p=0;
				if(exit[p+1]==true)
					p=p+1;
				else
				{
					cnt1=cnt1+1;
					p=p+1;
				}
				
			}
			cnt2=m;
			while(cnt2--)
			{ 
				if(q==1)
					q=n+1;
				if(exit[q-1]==true)
					q=q-1;
				else
				{
					cnt2=cnt2+1;
					q=q-1;
				}
				
			}
			exit[p]=exit[q]=false;
			if(left<n)
				cout<<",";
			printf("%3d",p);
			if(p!=q)
				printf("%3d",q);
			if(p==q)
				left=left-1;
			else
				left=left-2;
		}
		cout<<endl;
	}
    return 0;
}



这段代码就比我的高大上很多= =
#include<iostream>
#include<cstring>
#include<stdio.h>
using namespace std;
int main()
{
    int n,k,m;
    while(cin>>n>>k>>m&&n||k||m)
	{
		bool exit[25];
		int p=0,q=n+1,left=n,cnt;
		memset(exit,true,sizeof(exit));
		while(left)
		{
			cnt=(k%left?k%left:left);
			while(cnt--)
			{
				do
				{
					p=((p+1)%n?(p+1)%n:n);
				}while(exit[p]==false);
			}
			cnt=(m%left?m%left:left);
			while(cnt--)
			{
				do
				{
					q=((q-1)%n?(q-1)%n:n);
				}while(exit[q]==false);
			}
			if(left<n)
				cout<<",";
			printf("%3d",p);
			if(p!=q)
				printf("%3d",q);
			exit[p]=exit[q]=false;
			if(p==q)
				left=left-1;
			else
				left=left-2;
		}
		cout<<endl;
	}
    return 0;
}