首页 > 代码库 > POJ3461 Oulipo 【KMP】

POJ3461 Oulipo 【KMP】

Oulipo
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 22295 Accepted: 8905

Description

The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter ‘e‘. He was a member of the Oulipo group. A quote from the book:

Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…

Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive‘T‘s is not unusual. And they never use spaces.

So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {‘A‘‘B‘‘C‘, …, ‘Z‘} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.

Input

The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

  • One line with the word W, a string over {‘A‘‘B‘‘C‘, …, ‘Z‘}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
  • One line with the text T, a string over {‘A‘‘B‘‘C‘, …, ‘Z‘}, with |W| ≤ |T| ≤ 1,000,000.

Output

For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.

Sample Input

3
BAPC
BAPC
AZA
AZAZAZA
VERDI
AVERDXIVYERDIAN

Sample Output

1
3
0

奇了怪了,最近做题coding时觉得很顺利,但是debug的时候各种问题,今天第31行那里很久才发现漏洞   >_<|||

题意:给定一个模式串和主串,求主串中有多少个模式串(包含重叠)。

题解:这题是KMP的入门题了,只需要从左到右扫描一遍即可得出答案,next数组的意义为:若模式串第j个字符与主串第i个字符不匹配那么模式串指针j必须要回溯到一个位置重新与主串中的第i个字符开始匹配,next就是用来记录这个回溯的位置的,

#include <stdio.h>
#define maxn 10002
#define maxN 1000002

char str1[maxN], str2[maxn];
int next[maxn];

void getNext()
{
	int i = 0, j = -1;
	next[0] = -1;
	while(str2[i]){
		if(j == -1 || str2[i] == str2[j]){
			++i; ++j;
			if(str2[i] == str2[j]) next[i] = next[j];
			else next[i] = j;
		}else j = next[j];
	}
}

int KMP()
{	
	int ans = 0; 
	getNext();
	int i = 0, j = 0;	
	while(str1[i]){
		if(j == -1 || str1[i] == str2[j]){
			++i; ++j;
		}else j = next[j];
		
		if(j != -1 && !str2[j]){ //Attention!!!don't forget "j != -1"!
			++ans; j = next[j];
		}
	}
	return ans;
}

int main()
{
	//freopen("stdin.txt", "r", stdin);
	int t;
	scanf("%d", &t);
	while(t--){
		scanf("%s%s", str2, str1);
		printf("%d\n", KMP());
	}
	return 0;
}