首页 > 代码库 > poj2591 Set Definition(递推)

poj2591 Set Definition(递推)

转载请注明出处:http://blog.csdn.net/u012860063?viewmode=contents

题目链接:http://poj.org/problem?id=2591

Description

Set S is defined as follows: 
(1) 1 is in S; 
(2) If x is in S, then 2x + 1 and 3x + 1 are also in S; 
(3) No other element belongs to S. 

Find the N-th element of set S, if we sort the elements in S by increasing order.

Input

Input will contain several test cases; each contains a single positive integer N (1 <= N <= 10000000), which has been described above.

Output

For each test case, output the corresponding element in S.

Sample Input

100
254

Sample Output

418
1461

Source

POJ Monthly--2005.08.28,Static


代码如下:

#include <iostream>
using namespace std;
int a[10000017];
int main()
{
	int i, two = 1, three = 1;
	a[1] = 1;
	for(i = 2; i <= 10000000; i++)
	{
		a[i] = min(a[two]*2+1,a[three]*3+1);
		if(a[i] == a[two]*2+1)
			two++;

		if(a[i] == a[three]*3+1)
			three++;
	}
	int n;
	while(cin >> n)
	{
		cout<<a[n]<<endl;
	}
	return 0;
}