首页 > 代码库 > HDUJ 1042 N!

HDUJ 1042 N!

N!

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 53394    Accepted Submission(s): 15085


Problem Description
Given an integer N(0 ≤ N ≤ 10000), your task is to calculate N!
 

Input
One N in one line, process to the end of file.
 

Output
For each N, output N! in one line.
 

Sample Input
1 2 3
 

Sample Output
1 2 6




import java.util.Scanner;
import java.math.BigInteger;


public class yhrtr {

	public static void main(String[] args) {
		Scanner cin = new Scanner (System.in);
			 
		while(cin.hasNext())
		{
			BigInteger  s = BigInteger.ONE;
			int n = cin.nextInt();
			for(int i=1;i<=n;i++)
				s = s.multiply(BigInteger.valueOf(i));
			
			System.out.println(s);
		}
	}
}