首页 > 代码库 > hduj 1097 A hard puzzle

hduj 1097 A hard puzzle

A hard puzzle

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 28814    Accepted Submission(s): 10315


Problem Description
lcy gives a hard puzzle to feng5166,lwg,JGShining and Ignatius: gave a and b,how to know the a^b.everybody objects to this BT problem,so lcy makes the problem easier than begin.
this puzzle describes that: gave a and b,how to know the a^b‘s the last digit number.But everybody is too lazy to slove this problem,so they remit to you who is wise.
 

Input
There are mutiple test cases. Each test cases consists of two numbers a and b(0<a,b<=2^30)
 

Output
For each test case, you should output the a^b‘s last digit number.
 

Sample Input
7 66 8 800
 

Sample Output
9 6



#include<iostream>
#include<cstring>
using namespace std;

int q_mod(int a,int b,int c)
{
	int s=1;
	while(b)
	{
		if(b&1)   s=(s%10)*(a%c)%c;
		b=b>>1;
		a=(a%c)*(a%c)%c;
	}

	return s;
}

int main()
{
	int n,m;
	while(cin>>n>>m)
	{
		cout<<q_mod(n,m,10)<<endl;
	}

	return 0;
}


hduj 1097 A hard puzzle