首页 > 代码库 > HDU 1097 A hard puzzle【快速幂取模运算】

HDU 1097 A hard puzzle【快速幂取模运算】


A hard puzzle

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 30984    Accepted Submission(s): 11109


Problem Description
lcy gives a hard puzzle to feng5166,lwg,JGShining and Ignatius: gave a and b,how to know the a^b.everybody objects to this BT problem,so lcy makes the problem easier than begin.
this puzzle describes that: gave a and b,how to know the a^b‘s the last digit number.But everybody is too lazy to slove this problem,so they remit to you who is wise.
 

Input
There are mutiple test cases. Each test cases consists of two numbers a and b(0<a,b<=2^30)
 

Output
For each test case, you should output the a^b‘s last digit number.
 

Sample Input
7 66 8 800
 

Sample Output
9 6
 

Author
eddy
 



#include<stdio.h>

int pow_mod(__int64 a,__int64 b)
{
	int k=1;
	while(b)
	{
		if(b&1)
/*
	判断int型变量a是奇数还是偶数
	a&1 = 0 偶数
	a&1 = 1 奇数 
	
*/
			k=(k*a)%10;
		b>>=1;//右移一位  表示 将数除以2 
		a=(a*a)%10;
	}
	return k;
}

int main()
{
	__int64 a,b;
	int s;
	while(~scanf("%I64d%I64d",&a,&b))
	{
		s=pow_mod(a,b);
		printf("%d\n",s);
	}
	
	return 0;
} 





HDU 1097 A hard puzzle【快速幂取模运算】