首页 > 代码库 > hdu4882ZCC Loves Codefires(贪心)

hdu4882ZCC Loves Codefires(贪心)

题目链接:

啊哈哈,选我选我

题目:

ZCC Loves Codefires

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 182    Accepted Submission(s): 97


Problem Description
Though ZCC has many Fans, ZCC himself is a crazy Fan of a coder, called "Memset137".
It was on Codefires(CF), an online competitive programming site, that ZCC knew Memset137, and immediately became his fan.
But why?
Because Memset137 can solve all problem in rounds, without unsuccessful submissions; his estimation of time to solve certain problem is so accurate, that he can surely get an Accepted the second he has predicted. He soon became IGM, the best title of Codefires. Besides, he is famous for his coding speed and the achievement in the field of Data Structures.
After become IGM, Memset137 has a new goal: He wants his score in CF rounds to be as large as possible.
What is score? In Codefires, every problem has 2 attributes, let‘s call them Ki and Bi(Ki, Bi>0). if Memset137 solves the problem at Ti-th second, he gained Bi-Ki*Ti score. It‘s guaranteed Bi-Ki*Ti is always positive during the round time.
Now that Memset137 can solve every problem, in this problem, Bi is of no concern. Please write a program to calculate the minimal score he will lose.(that is, the sum of Ki*Ti).
 

Input
The first line contains an integer N(1≤N≤10^5), the number of problem in the round.
The second line contains N integers Ei(1≤Ei≤10^4), the time(second) to solve the i-th problem.
The last line contains N integers Ki(1≤Ki≤10^4), as was described.
 

Output
One integer L, the minimal score he will lose.
 

Sample Input
3 10 10 20 1 2 3
 

Sample Output
150
Hint
Memset137 takes the first 10 seconds to solve problem B, then solves problem C at the end of the 30th second. Memset137 gets AK at the end of the 40th second. L = 10 * 2 + (10+20) * 3 + (10+20+10) * 1 = 150.
 

Author
镇海中学
 

Source
2014 Multi-University Training Contest 2
 

Recommend
We have carefully selected several similar problems for you:  4881 4880 4879 4878 4877 

哎。。比赛的时候将double写成float,悲剧。。。以为思路错了。。结果没有。。

我的思路是既然求最小的失去分数。。故我可以求每个题目的性价比。。选性价比低的题目先做。。

代码为:

#include<cstdio>
#include<algorithm>
#include<iostream>
using namespace std;

const int maxn=100000+10;
int n;

struct no
{
    int time;
    int score;
    double average;
}node[maxn];


bool cmp(no a,no b)
{
    return a.average<b.average;
}

int main()
{
    __int64 ans,pd;
    while(~scanf("%d",&n))
    {
        for(int i=1;i<=n;i++)
            scanf("%d",&node[i].time);
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&node[i].score);
            node[i].average=(node[i].time*1.0)/node[i].score;
        }
        sort(node+1,node+1+n,cmp);
        pd=ans=0;
        for(int i=1;i<=n;i++)
        {
            pd=node[i].time+pd;
            ans=ans+pd*node[i].score;
        }
        printf("%I64d\n",ans);
    }
    return 0;
}