首页 > 代码库 > hdu1010-Tempter of the Bone DFS深搜入门题+奇偶剪枝

hdu1010-Tempter of the Bone DFS深搜入门题+奇偶剪枝

Tempter of the Bone

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 69699    Accepted Submission(s): 19176


Problem Description
The doggie found a bone in an ancient maze, which fascinated him a lot. However, when he picked it up, the maze began to shake, and the doggie could feel the ground sinking. He realized that the bone was a trap, and he tried desperately to get out of this maze.

The maze was a rectangle with sizes N by M. There was a door in the maze. At the beginning, the door was closed and it would open at the T-th second for a short period of time (less than 1 second). Therefore the doggie had to arrive at the door on exactly the T-th second. In every second, he could move one block to one of the upper, lower, left and right neighboring blocks. Once he entered a block, the ground of this block would start to sink and disappear in the next second. He could not stay at one block for more than one second, nor could he move into a visited block. Can the poor doggie survive? Please help him.
 

Input
The input consists of multiple test cases. The first line of each test case contains three integers N, M, and T (1 < N, M < 7; 0 < T < 50), which denote the sizes of the maze and the time at which the door will open, respectively. The next N lines give the maze layout, with each line containing M characters. A character is one of the following:

‘X‘: a block of wall, which the doggie cannot enter; 
‘S‘: the start point of the doggie; 
‘D‘: the Door; or
‘.‘: an empty block.

The input is terminated with three 0‘s. This test case is not to be processed.
 

Output
For each test case, print in one line "YES" if the doggie can survive, or "NO" otherwise.
 

Sample Input
4 4 5 S.X. ..X. ..XD .... 3 4 5 S.X. ..X. ...D 0 0 0
 

Sample Output
NO YES
下面是未剪枝的,可作为模板学习DFS,原理容易理解,难的是代码的实现:
#include<stdio.h>
#include<iostream>
#include<math.h>
#include<string.h>
using namespace std;
int n,m,t;
int dir[4][2]={{0,-1},{0,1},{1,0},{-1,0}};
char map[9][9];
int sx,sy;
int ex,ey;
bool escape;

void dfs(int x,int y,int ant)
{


    if(x==ex&&y==ey&&ant==t)
    {
        escape=true;
        return ;
    }
    for(int i=0;i<4;i++)
    {
        int xi=x+dir[i][0];
        int yi=y+dir[i][1];

        if(xi>=0&&xi<n&&yi>=0&&yi<m&&map[xi][yi]!='X')
        {
            map[xi][yi]='X';
            ant++;
            dfs(xi,yi,ant);
            ant--;
            if(escape==true)
                return ;
            map[xi][yi]='.';


        }

    }
    return ;
}
int main()
{
  while(scanf("%d%d%d",&n,&m,&t)!=EOF&&n)
  {

      escape=false;
     // memset(map,0,sizeof(map));
      for(int i=0;i<n;i++)
      {
          scanf("%s",map[i]);
          for(int j=0;j<m;j++)
          {
              if(map[i][j]=='S')
              {
                  sx=i;
                  sy=j;
              }
              if(map[i][j]=='D')
              {
                  ex=i;
                  ey=j;
              }
          }
      }
      map[sx][sy] = 'X';
      dfs(sx,sy,0);
      if(escape==true)
      {
          printf("YES\n");
      }
      else
        printf("NO\n");
  }
  return 0;
}
剪完枝后完美AC:
<pre name="code" class="html">#include<stdio.h>
#include<iostream>
#include<math.h>
#include<string.h>
#include<stdlib.h>
using namespace std;
int n,m,t;
int dir[4][2]={{0,-1},{0,1},{1,0},{-1,0}};
char map[9][9];
int sx,sy;
int ex,ey;
bool escape;

void dfs(int x,int y,int ant)
{

      int temp;
    if(x==ex&&y==ey&&ant==t)
    {
        escape=true;
        return ;
    }
  //   temp=(t-ant)-abs(sx-ex)-abs(sy-ey);
  // if(temp<0||temp&1) return;
  if(((t-ant)+abs(x-ex)+abs(y-ey))%2!=0) //关键剪枝
    return ;
    for(int i=0;i<4;i++)
    {
        int xi=x+dir[i][0];
        int yi=y+dir[i][1];

        if(xi>=0&&xi<n&&yi>=0&&yi<m&&map[xi][yi]!='X')
        {
            map[xi][yi]='X';
            ant++;
            dfs(xi,yi,ant);
            ant--;
            if(escape==true)
                return ;
            map[xi][yi]='.';


        }

    }
    return ;
}
int main()
{
  while(scanf("%d%d%d",&n,&m,&t)!=EOF&&n)
  {

      escape=false;
     // memset(map,0,sizeof(map));
      for(int i=0;i<n;i++)
      {
          scanf("%s",map[i]);
          for(int j=0;j<m;j++)
          {
              if(map[i][j]=='S')
              {
                  sx=i;
                  sy=j;
              }
              if(map[i][j]=='D')
              {
                  ex=i;
                  ey=j;
              }
          }
      }
      map[sx][sy] = 'X';
      dfs(sx,sy,0);
      if(escape==true)
      {
          printf("YES\n");
      }
      else
        printf("NO\n");
  }
  return 0;
}


详细参考:http://acm.hdu.edu.cn/forum/read.php?tid=6158&page=1