首页 > 代码库 > Tempter of the Bone(杭电1010)(DFS+奇偶剪枝)

Tempter of the Bone(杭电1010)(DFS+奇偶剪枝)

Tempter of the Bone

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 74916    Accepted Submission(s): 20481


Problem Description
The doggie found a bone in an ancient maze, which fascinated him a lot. However, when he picked it up, the maze began to shake, and the doggie could feel the ground sinking. He realized that the bone was a trap, and he tried desperately to get out of this maze.

The maze was a rectangle with sizes N by M. There was a door in the maze. At the beginning, the door was closed and it would open at the T-th second for a short period of time (less than 1 second). Therefore the doggie had to arrive at the door on exactly the T-th second. In every second, he could move one block to one of the upper, lower, left and right neighboring blocks. Once he entered a block, the ground of this block would start to sink and disappear in the next second. He could not stay at one block for more than one second, nor could he move into a visited block. Can the poor doggie survive? Please help him.
 

Input
The input consists of multiple test cases. The first line of each test case contains three integers N, M, and T (1 < N, M < 7; 0 < T < 50), which denote the sizes of the maze and the time at which the door will open, respectively. The next N lines give the maze layout, with each line containing M characters. A character is one of the following:

‘X‘: a block of wall, which the doggie cannot enter; 
‘S‘: the start point of the doggie; 
‘D‘: the Door; or
‘.‘: an empty block.

The input is terminated with three 0‘s. This test case is not to be processed.
 

Output
For each test case, print in one line "YES" if the doggie can survive, or "NO" otherwise.
 

Sample Input
4 4 5 S.X. ..X. ..XD .... 3 4 5 S.X. ..X. ...D 0 0 0
 

Sample Output
NO YES
 

Author
ZHANG, Zheng
 

Source
ZJCPC2004

关键: 奇偶剪枝!参考:奇偶剪枝—百度百科
核心代码:
ans=t-time-abs(dx-x)-abs(dy-y); 
if(ans<0||ans&1) return;

代码:
#include<stdio.h>
#include<math.h>
#include<algorithm>
using namespace std;
char map[9][9];
int n,m,t,x,dx,y,dy,ok;
int a[4][2]={{0,1},{0,-1},{1,0},{-1,0}};
void dfs(int x,int y,int time)
{
	int i,ans;
	if(x==dx&&y==dy&&time==t) ok=1;
	if(ok) return;
	if(x<1||y<1||x>n||y>m) return;  //搜索到边界 。 
	ans=t-time-abs(dx-x)-abs(dy-y); //奇偶剪枝,感觉好吊。
	if(ans<0||ans&1) return;
	for(i=0;i<4;i++)
	{
		if(map[x+a[i][0]][y+a[i][1]]!='X') 
		{
			map[x+a[i][0]][y+a[i][1]]='X';
			dfs(x+a[i][0],y+a[i][1],time+1);
			map[x+a[i][0]][y+a[i][1]]='.';
		}
	}
}
int main()
{
	int i,j,k;
	while(scanf("%d%d%d",&n,&m,&t)!=EOF)
	{
		getchar();  //注意这个getchar();不能省略,否则输出一直是NO,找了1个多小时,无奈了。 
		if(n==0&&m==0&&t==0)
		    break;
		for(i=1,k=0;i<=n;i++)
		{
			for(j=1;j<=m;j++)
			{
				scanf("%c",&map[i][j]);
				if(map[i][j]=='S') 
				{
				    x=i;
					y=j; 
				}
			    if(map[i][j]=='D')
				{
					dx=i;
					dy=j;
				}
				if(map[i][j]=='X')
				    k++;	
			}
			getchar();
		}
		if(n*m-k<t)  //最长的搜索时间。 
		   printf("NO\n");
		else{
		ok=0;
		map[x][y]='X';  //标记已经访问过了。 
		dfs(x,y,0);
		if(ok==1)
		    printf("YES\n");
		else    
		    printf("NO\n");}
	}
	return 0;
}

Tempter of the Bone(杭电1010)(DFS+奇偶剪枝)