首页 > 代码库 > 概率dp poj2096

概率dp poj2096

Collecting Bugs
Time Limit: 10000MS Memory Limit: 64000K
Total Submissions: 2341 Accepted: 1126
Case Time Limit: 2000MS Special Judge

Description

Ivan is fond of collecting. Unlike other people who collect post stamps, coins or other material stuff, he collects software bugs. When Ivan gets a new program, he classifies all possible bugs into n categories. Each day he discovers exactly one bug in the program and adds information about it and its category into a spreadsheet. When he finds bugs in all bug categories, he calls the program disgusting, publishes this spreadsheet on his home page, and forgets completely about the program. 
Two companies, Macrosoft and Microhard are in tight competition. Microhard wants to decrease sales of one Macrosoft program. They hire Ivan to prove that the program in question is disgusting. However, Ivan has a complicated problem. This new program has s subcomponents, and finding bugs of all types in each subcomponent would take too long before the target could be reached. So Ivan and Microhard agreed to use a simpler criteria --- Ivan should find at least one bug in each subsystem and at least one bug of each category. 
Macrosoft knows about these plans and it wants to estimate the time that is required for Ivan to call its program disgusting. It‘s important because the company releases a new version soon, so it can correct its plans and release it quicker. Nobody would be interested in Ivan‘s opinion about the reliability of the obsolete version. 
A bug found in the program can be of any category with equal probability. Similarly, the bug can be found in any given subsystem with equal probability. Any particular bug cannot belong to two different categories or happen simultaneously in two different subsystems. The number of bugs in the program is almost infinite, so the probability of finding a new bug of some category in some subsystem does not reduce after finding any number of bugs of that category in that subsystem. 
Find an average time (in days of Ivan‘s work) required to name the program disgusting.

Input

Input file contains two integer numbers, n and s (0 < n, s <= 1 000).

Output

Output the expectation of the Ivan‘s working days needed to call the program disgusting, accurate to 4 digits after the decimal point.

Sample Input

1 2

Sample Output

3.0000

Source

Northeastern Europe 2004, Northern Subregion

[Submit]   [Go Back]   [Status]   [Discuss]

Home Page   Go Back  To top

题意:一个软件有n种bug,s个子系统,Ivan每天能发现一个bug,每个bug属于一个子系统,属于其中一种bug,求出现n种bug且每个子系统出现过bug的期望天数。

令dp[i][j]表示出现n种bug,j个子系统后达到目标状态所需要的期望天数,则有,dp[n][s]=0;

dp[i][j]=(dp[i+1][j]*div(n-i,n)*div(j,s)+dp[i][j+1]*div(i,n)*div(s-j,s)+dp[i+1][j+1]*div(n-i,n)*div(s-j,s)+1)/(1-div(i,n)*div(j,s));

#include <iostream>
#include <cstring>
#include <cstdio>
#define MAXN 1010
using namespace std;
double dp[MAXN][MAXN];
double div(int a,int b)
{
    //cout<<a<<' '<<b<<endl;
    return (double)a/b;
}
int main()
{
    int n,s;

    while(scanf("%d%d",&n,&s)!=EOF)
    {
        dp[n][s]=0;
        for(int i=n;i>=0;i--)
        for(int j=s;j>=0;j--)
        {
              if(i==n&&j==s)continue;
              dp[i][j]=(dp[i+1][j]*div(n-i,n)*div(j,s)+dp[i][j+1]*div(i,n)*div(s-j,s)+dp[i+1][j+1]*div(n-i,n)*div(s-j,s)+1)/(1-div(i,n)*div(j,s));
        }
        printf("%.4f\n",dp[0][0]);
    }
    return 0;
}