首页 > 代码库 > hdoj 1892(二维树状数组)
hdoj 1892(二维树状数组)
Problem H
Time Limit : 5000/3000ms (Java/Other) Memory Limit : 65535/32768K (Java/Other)
Total Submission(s) : 8 Accepted Submission(s) : 3
Font: Times New Roman | Verdana | Georgia
Font Size: ← →
Problem Description
When coming into our training room, a lot of books are in my eyes. And every time the books are moving from one place to another one. Now give you the position of the books at the early of the day. And the moving information of the books the day, your work is to tell me how many books are stayed in some rectangles.
To make the problem easier, we divide the room into different grids and a book can only stayed in one grid. The length and the width of the room are less than 1000. I can move one book from one position to another position, take away one book from a position or bring in one book and put it on one position.
Input
For each test case, in the first line there is an Integer Q(1<Q<=100,000), means the queries of the case. Then followed by Q queries.
There are 4 kind of queries, sum, add, delete and move.
For example:
S x1 y1 x2 y2 means you should tell me the total books of the rectangle used (x1,y1)-(x2,y2) as the diagonal, including the two points.
A x1 y1 n1 means I put n1 books on the position (x1,y1)
D x1 y1 n1 means I move away n1 books on the position (x1,y1), if less than n1 books at that position, move away all of them.
M x1 y1 x2 y2 n1 means you move n1 books from (x1,y1) to (x2,y2), if less than n1 books at that position, move away all of them.
Make sure that at first, there is one book on every grid and 0<=x1,y1,x2,y2<=1000,1<=n1<=100.
Output
For each "S" query, just print out the total number of books in that area.
Sample Input
23S 1 1 1 1A 1 1 2S 1 1 1 13S 1 1 1 1A 1 1 2S 1 1 1 2
Sample Output
Case 1:13Case 2:14
代码:
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int n=1010;
int c[n+1][n+1];
int lowbit(int x)
{
return x&(-x);
}
void update(int x,int y,int val)
{
for(int i=x;i<=n;i+=lowbit(i))
{
for(int j=y;j<=n;j+=lowbit(j))
{
c[i][j]+=val;
}
}
}
int getsum(int x,int y)
{
int cnt=0;
for(int i=x;i>=1;i-=lowbit(i))
{
for(int j=y;j>=1;j-=lowbit(j))
{
cnt+=c[i][j];
}
}
return cnt;
}
int val[n+1][n+1];
int main()
{
int ci;scanf("%d",&ci);
int pl=1;
while(ci--)
{
memset(c,0,sizeof(c));
printf("Case %d:\n",pl++);
for(int i=1;i<=n;i++)
{
for(int j=1;j<=n;j++)
{
update(i,j,1);
val[i][j]=1;
}
}
int sa;scanf("%d",&sa);
while(sa--)
{
char ch;cin>>ch;
if(ch==‘S‘)
{
int xx1,yy1,xx2,yy2;
scanf("%d%d%d%d",&xx1,&yy1,&xx2,&yy2);
xx1++,xx2++,yy1++,yy2++;//从1开始
int x1,x2,y1,y2;
x1=min(xx1,xx2);x2=max(xx1,xx2);
y1=min(yy1,yy2);y2=max(yy1,yy2);
int cnt=getsum(x2,y2)-getsum(x1-1,y2)-getsum(x2,y1-1)+getsum(x1-1,y1-1);
printf("%d\n",cnt);
}
else if(ch==‘A‘)
{
int x,y,l;
scanf("%d%d%d",&x,&y,&l);
x++,y++;
update(x,y,l);
val[x][y]+=l;
}
else if(ch==‘D‘)
{
int x,y,l;
scanf("%d%d%d",&x,&y,&l);
x++,y++;
if(l>val[x][y]) l=val[x][y];//important
update(x,y,-l);
val[x][y]+=-l;
}
else
{
int x1,x2,y1,y2,l;
scanf("%d%d%d%d%d",&x1,&y1,&x2,&y2,&l);
x1++,x2++,y1++,y2++;
if(l>val[x1][y1]) l=val[x1][y1];//important
update(x1,y1,-l);
val[x1][y1]+=-l;
update(x2,y2,l);
val[x2][y2]+=l;
}
}
}
return 0;
}