首页 > 代码库 > poj 1469 COURSES

poj 1469 COURSES

COURSES
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 17443 Accepted: 6873

Description

Consider a group of N students and P courses. Each student visits zero, one or more than one courses. Your task is to determine whether it is possible to form a committee of exactly P students that satisfies simultaneously the conditions: 

  • every student in the committee represents a different course (a student can represent a course if he/she visits that course) 
  • each course has a representative in the committee 

Input

Your program should read sets of data from the std input. The first line of the input contains the number of the data sets. Each data set is presented in the following format: 

P N 
Count1 Student1 1 Student1 2 ... Student1 Count1 
Count2 Student2 1 Student2 2 ... Student2 Count2 
... 
CountP StudentP 1 StudentP 2 ... StudentP CountP 

The first line in each data set contains two positive integers separated by one blank: P (1 <= P <= 100) - the number of courses and N (1 <= N <= 300) - the number of students. The next P lines describe in sequence of the courses ?from course 1 to course P, each line describing a course. The description of course i is a line that starts with an integer Count i (0 <= Count i <= N) representing the number of students visiting course i. Next, after a blank, you抣l find the Count i students, visiting the course, each two consecutive separated by one blank. Students are numbered with the positive integers from 1 to N. 
There are no blank lines between consecutive sets of data. Input data are correct. 

Output

The result of the program is on the standard output. For each input data set the program prints on a single line "YES" if it is possible to form a committee and "NO" otherwise. There should not be any leading blanks at the start of the line.

Sample Input

2
3 3
3 1 2 3
2 1 2
1 1
3 3
2 1 3
2 1 3
1 1

Sample Output

YES
NO



分析:

还是二分匹配,不过开始用cin就一直TLE,没有初始化也一直WA 。简直是蛋疼啊。


#include<stdio.h>
#include<iostream>
#include<algorithm>
using namespace std;
#define M 305

int p,n,a[M];
int map[M][M],flag[M],pre[M];

int find(int x)
{
  for(int i=1;i<=n;i++)
  {
    if(map[x][i]==1 && flag[i]==0)
	{
	 flag[i]=1;
	 if(pre[i]==0 || find(pre[i]))
	 {
		 pre[i]=x;
		 return 1;
	 }
	}
  }
  return 0;
}

int main ()
{
  int T;
  int i,j,k;
  scanf("%d",&T);
  while(T--)
  {
   memset(map,0,sizeof(map));
   memset(pre,0,sizeof(pre));
   scanf("%d%d",&p,&n);
   for(i=1;i<=p;i++)
   {
     scanf("%d",&k);
	 for(j=1;j<=k;j++)
	 {
		 scanf("%d",&a[j]);
		 map[i][a[j]]=1;
	 }
   }

   int sum=0; 
   for(i=1;i<=p;i++)
   {
       memset(flag,0,sizeof(flag));
	   if(find(i))
		 sum++;
   }
   //cout<<sum<<endl;
   if(sum==p)
	   printf("YES\n");
   else 
	   printf("NO\n");
  }
 return 0;
}