首页 > 代码库 > HDU - 4950 Monster

HDU - 4950 Monster


Problem Description
Teacher Mai has a kingdom. A monster has invaded this kingdom, and Teacher Mai wants to kill it.

Monster initially has h HP. And it will die if HP is less than 1.

Teacher Mai and monster take turns to do their action. In one round, Teacher Mai can attack the monster so that the HP of the monster will be reduced by a. At the end of this round, the HP of monster will be increased by b.

After k consecutive round‘s attack, Teacher Mai must take a rest in this round. However, he can also choose to take a rest in any round.

Output "YES" if Teacher Mai can kill this monster, else output "NO".
 

Input
There are multiple test cases, terminated by a line "0 0 0 0".

For each test case, the first line contains four integers h,a,b,k(1<=h,a,b,k <=10^9).
 

Output
For each case, output "Case #k: " first, where k is the case number counting from 1. Then output "YES" if Teacher Mai can kill this monster, else output "NO".
 

Sample Input
5 3 2 2 0 0 0 0
 

Sample Output
Case #1: NO

题意:给你怪兽的血,你的攻击伤害,怪兽每轮回的血,你可以选择在任意一轮休息,但是在连续的k轮后必须休息

思路:首先不休息的话肯定是最优的,先判断第一轮会不会直接打死,再判断第k轮打完后不回血的情况下会不会死,再者就是连续的k+1轮会不会给怪兽造成伤害

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
typedef long long ll;
using namespace std;

ll h, a, b, k;

int main() {
	int cas = 1;
	while (scanf("%lld%lld%lld%lld", &h, &a, &b, &k) != EOF && h+a+b+k) {
		printf("Case #%d: ", cas++);
		if (h <= a) {
			puts("YES");
			continue;
		}
		if (h-k*a+(k-1)*b <= 0 || ((k+1)*b-k*a) < 0)
			puts("YES");
		else puts("NO");
	}
	return 0;
}