首页 > 代码库 > hdu 4950 Monster(数学题,多校8)

hdu 4950 Monster(数学题,多校8)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=4950


Monster

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 220    Accepted Submission(s): 92


Problem Description
Teacher Mai has a kingdom. A monster has invaded this kingdom, and Teacher Mai wants to kill it.

Monster initially has h HP. And it will die if HP is less than 1.

Teacher Mai and monster take turns to do their action. In one round, Teacher Mai can attack the monster so that the HP of the monster will be reduced by a. At the end of this round, the HP of monster will be increased by b.

After k consecutive round‘s attack, Teacher Mai must take a rest in this round. However, he can also choose to take a rest in any round.

Output "YES" if Teacher Mai can kill this monster, else output "NO".
 
Input
There are multiple test cases, terminated by a line "0 0 0 0".

For each test case, the first line contains four integers h,a,b,k(1<=h,a,b,k <=10^9).
 
Output
For each case, output "Case #k: " first, where k is the case number counting from 1. Then output "YES" if Teacher Mai can kill this monster, else output "NO".
 
Sample Input
5 3 2 2 0 0 0 0
 
Sample Output
Case #1: NO
 
Source
2014 Multi-University Training Contest 8 

题意:给出怪兽的血量h,玩家每回合造成的伤害a,每一回合结束后怪兽会回血量b,玩家在连续攻击k回合后须休息一次(也可以在K回合之前的任意回合休息),判断玩家能否杀死怪兽!、

思路:贪心,必然是打了K回合后再休息!具体见代码解析;



官方题解:http://blog.sina.com.cn/u/1809706204

代码如下:

#include<cstdio>
typedef __int64 LL;
int main()
{
    LL h,a,b,k;
    LL cas = 0;
    while(~scanf("%I64d%I64d%I64d%I64d",&h,&a,&b,&k))
    {
        if(h==0 && a==0 && b==0 && k==0)
            break;
        printf("Case #%I64d: ",++cas);
        if(h <= a)//第一回合怪兽就死亡
        {
            printf("YES\n");
            continue;
        }
        if((k-1)*(-a+b)-a+h <= 0)//前K回合怪兽死亡
        {
            printf("YES\n");
            continue;
        }
        if(k*(-a+b)+b < 0)//每K回合后怪兽的血量在减少
        {
            printf("YES\n");
            continue;
        }
        printf("NO\n");
    }
    return 0;
}