首页 > 代码库 > poj 1159 Palindrome lcs+滚动数组

poj 1159 Palindrome lcs+滚动数组

点击打开链接题目链接

Palindrome
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 52910 Accepted: 18248

Description

A palindrome is a symmetrical string, that is, a string read identically from left to right as well as from right to left. You are to write a program which, given a string, determines the minimal number of characters to be inserted into the string in order to obtain a palindrome. 

As an example, by inserting 2 characters, the string "Ab3bd" can be transformed into a palindrome ("dAb3bAd" or "Adb3bdA"). However, inserting fewer than 2 characters does not produce a palindrome. 

Input

Your program is to read from standard input. The first line contains one integer: the length of the input string N, 3 <= N <= 5000. The second line contains one string with length N. The string is formed from uppercase letters from ‘A‘ to ‘Z‘, lowercase letters from ‘a‘ to ‘z‘ and digits from ‘0‘ to ‘9‘. Uppercase and lowercase letters are to be considered distinct.

Output

Your program is to write to standard output. The first line contains one integer, which is the desired minimal number.

Sample Input

5
Ab3bd

Sample Output

2

说白了就是求和自己相反字符串的lcs

short可以卡过

还是老老实实写滚动数组吧

#include<cstdio>
#include<cstring>
int dp[2][5050];
char str1[5050],str2[5050];
int maxx(int a,int b)
{
    return a>b?a:b;
}
int main()
{
    int n,i,j;
    int l;
    while(scanf("%d",&n)!=EOF)
    {
        scanf("%s",str1+1);
        for(i=1;i<=n;i++)
        {
            str2[n+1-i]=str1[i];
        }
        memset(dp,0,sizeof(dp));
        int flag=1;
        int xx=0;
        for(i=1;i<=n;i++)
        {
            flag=1-flag;
            for(j=1;j<=n;j++)
            {

                if(str1[i]==str2[j])
                {
                    dp[flag][j]=dp[1-flag][j-1]+1;
                }
                else
                {
                    dp[flag][j]=maxx(dp[flag][j-1],dp[1-flag][j]);
                }
                xx=maxx(xx,dp[flag][j]);
               // printf("%d ",dp[flag][j]);
            }
           // puts("");
        }
        printf("%d\n",n-xx);
    }
}