首页 > 代码库 > POJ 1159 Palindrome DP

POJ 1159 Palindrome DP

Palindrome
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 51913 Accepted: 17877

Description

A palindrome is a symmetrical string, that is, a string read identically from left to right as well as from right to left. You are to write a program which, given a string, determines the minimal number of characters to be inserted into the string in order to obtain a palindrome.

As an example, by inserting 2 characters, the string "Ab3bd" can be transformed into a palindrome ("dAb3bAd" or "Adb3bdA"). However, inserting fewer than 2 characters does not produce a palindrome.

Input

Your program is to read from standard input. The first line contains one integer: the length of the input string N, 3 <= N <= 5000. The second line contains one string with length N. The string is formed from uppercase letters from ‘A‘ to ‘Z‘, lowercase letters from ‘a‘ to ‘z‘ and digits from ‘0‘ to ‘9‘. Uppercase and lowercase letters are to be considered distinct.

Output

Your program is to write to standard output. The first line contains one integer, which is the desired minimal number.

Sample Input

5
Ab3bd

Sample Output

2



#include<iostream>
#include<cstring>
using namespace std;

int v[2][5005];
char c1[5010],c2[5010];

int max(int x,int y)
{
	return x>y?x:y;
}

int main()
{
	int n;
	while(cin>>n)
	{ 
		int i;
		for(i=1;i<=n;i++)
		{
			cin>>c1[i];
			c2[n-i+1]=c1[i];
		}

		memset(v,0,sizeof(v));
		int j;
		int m=0;
		for(i=1;i<=n;i++)
		{
			for(j=1;j<=n;j++)
			{
				if(c1[i]==c2[j])
					v[i%2][j]=v[(i-1)%2][j-1]+1;
				else
					v[i%2][j]=max(v[(i-1)%2][j],v[i%2][j-1]);
				if(m<v[i%2][j])
					m=v[i%2][j];
			}
			
		}

		cout<<n-m<<endl;
	}

	return 0;
}