首页 > 代码库 > Palindrome(poj1159)(动态规划)

Palindrome(poj1159)(动态规划)

Palindrome
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 53877 Accepted: 18610

Description

A palindrome is a symmetrical string, that is, a string read identically from left to right as well as from right to left. You are to write a program which, given a string, determines the minimal number of characters to be inserted into the string in order to obtain a palindrome. 

As an example, by inserting 2 characters, the string "Ab3bd" can be transformed into a palindrome ("dAb3bAd" or "Adb3bdA"). However, inserting fewer than 2 characters does not produce a palindrome. 

Input

Your program is to read from standard input. The first line contains one integer: the length of the input string N, 3 <= N <= 5000. The second line contains one string with length N. The string is formed from uppercase letters from ‘A‘ to ‘Z‘, lowercase letters from ‘a‘ to ‘z‘ and digits from ‘0‘ to ‘9‘. Uppercase and lowercase letters are to be considered distinct.

Output

Your program is to write to standard output. The first line contains one integer, which is the desired minimal number.

Sample Input

5
Ab3bd

Sample Output

2

Source

IOI 2000
/*用short类型险过。
*/
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
short dp[5002][5002];
int main()
{
	char a[5001],s[5001];
	int i,j,n;
	scanf("%d",&n); 
	scanf("%s",a);
	memset(dp,0,sizeof(dp));
	for(i=0,j=n-1;i<n;i++,j--)
	{
		s[i]=a[j];
	}
	for(i=1;i<=n;i++)
	{
		for(j=1;j<=n;j++)
		{
			if(a[i-1]==s[j-1])
				dp[i][j]=dp[i-1][j-1]+1;
			else
				dp[i][j]=max(dp[i-1][j],dp[i][j-1]);
		}
	}
	printf("%d\n",n-dp[n][n]);
	return 0;
}

Palindrome(poj1159)(动态规划)