首页 > 代码库 > poj 1159 Palindrome

poj 1159 Palindrome

Palindrome
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 50914 Accepted: 17537

Description

A palindrome is a symmetrical string, that is, a string read identically from left to right as well as from right to left. You are to write a program which, given a string, determines the minimal number of characters to be inserted into the string in order to obtain a palindrome. 

As an example, by inserting 2 characters, the string "Ab3bd" can be transformed into a palindrome ("dAb3bAd" or "Adb3bdA"). However, inserting fewer than 2 characters does not produce a palindrome. 

Input

Your program is to read from standard input. The first line contains one integer: the length of the input string N, 3 <= N <= 5000. The second line contains one string with length N. The string is formed from uppercase letters from ‘A‘ to ‘Z‘, lowercase letters from ‘a‘ to ‘z‘ and digits from ‘0‘ to ‘9‘. Uppercase and lowercase letters are to be considered distinct.

Output

Your program is to write to standard output. The first line contains one integer, which is the desired minimal number.

Sample Input

5
Ab3bd

Sample Output

2

需要加的字符的个数=原来字符串的长度-原来字符串和逆字符串的最长公共子序列的长度。

用滚动数组或用short int防止超内存。

#include"stdio.h"
#include"string.h"
#define mmax(a,b) (a>b?a:b)
#define N 5005
short  dp[2][N];
int main()
{
    int i,j,n;
    char str[N],s[N];
    while(scanf("%d",&n)!=-1)
    {
        scanf("%s",str);
        for(i=0;i<n;i++)
        {
            s[i]=str[n-1-i];
        }
        s[n]='\0';
        memset(dp,0,sizeof(dp));
        int ans=0;
        for(i=0;i<n;i++)
        {
            for(j=0;j<n;j++)
            {
                if(str[i]==s[j])
                {
                    dp[(i+1)%2][j+1]=dp[i%2][j]+1;
                }
                else
                {
                    dp[(i+1)%2][j+1]=mmax(dp[(i+1)%2][j],dp[i%2][j+1]);
                }
                ans=mmax(ans,dp[(i+1)%2][j+1]);
            }
        }
        printf("%d\n",n-ans);
    }
    return 0;
}