首页 > 代码库 > POJ1159

POJ1159


Palindrome
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 51790 Accepted: 17831

Description

A palindrome is a symmetrical string, that is, a string read identically from left to right as well as from right to left. You are to write a program which, given a string, determines the minimal number of characters to be inserted into the string in order to obtain a palindrome.

As an example, by inserting 2 characters, the string "Ab3bd" can be transformed into a palindrome ("dAb3bAd" or "Adb3bdA"). However, inserting fewer than 2 characters does not produce a palindrome.

Input

Your program is to read from standard input. The first line contains one integer: the length of the input string N, 3 <= N <= 5000. The second line contains one string with length N. The string is formed from uppercase letters from ‘A‘ to ‘Z‘, lowercase letters from ‘a‘ to ‘z‘ and digits from ‘0‘ to ‘9‘. Uppercase and lowercase letters are to be considered distinct.

Output

Your program is to write to standard output. The first line contains one integer, which is the desired minimal number.

Sample Input

5
Ab3bd

Sample Output

2

Source

IOI 2000

题意:给出一字符串,求使其成为回文串所需要的最小字符数。

思路:所求=回文串长度—原字符串长度。

分析:回文串长度,
           如果s[0]=s[n-1],则c[0][n-1]=c[1][n-2];
           如果不等,则c[0][n-1]=min{c[0][n-2],c[1][n-1]}+1;
           数组大小,
           5000*5000的int肯定开不下,看到discuss里面有人用short水过,
           就像我前一篇转载的所说开滚动数组能节省空间,因为有些地方我们访问过
           后就丢弃不用了所以可以进行“滚动”,滚动成2*5000.
AC代码:
import java.util.*;
public class Main {

	public static void main(String[] args) {
		Scanner scan=new Scanner(System.in);
		int n=scan.nextInt();
		String str=scan.next();
		char s[]=new char[5005];
		s=str.toCharArray();
		int c[][]=new int[2][5000];
		for(int i=0;i<2;i++){
			for(int j=0;j<5000;j++){
				c[i][j]=0;
			}
		}
		for(int i=n-2;i>=0;i--){
			for(int j=i+1;j<n;j++){
				int t1=i%2;
				int t2=(i+1)%2;
				if(s[i]==s[j])
					c[t1][j]=c[t2][j-1];
				if(s[i]!=s[j]){
					c[t1][j]=1+Math.min(c[t2][j], c[t1][j-1]);
				}
			}
		}
		System.out.println(c[0][n-1]);
	}

}