首页 > 代码库 > zoj 3659 Conquer a New Region 并查集+贪心

zoj 3659 Conquer a New Region 并查集+贪心

点击打开链接题目链接



Conquer a New Region

Time Limit: 5 Seconds      Memory Limit: 32768 KB

The wheel of the history rolling forward, our king conquered a new region in a distant continent.

There are N towns (numbered from 1 to N) in this region connected by several roads. It‘s confirmed that there is exact one route between any two towns. Traffic is important while controlled colonies are far away from the local country. We define the capacity C(i, j) of a road indicating it is allowed to transport at most C(i, j) goods between town i and town j if there is a road between them. And for a route between i and j, we define a value S(i, j) indicating the maximum traffic capacity between i and j which is equal to the minimum capacity of the roads on the route.

Our king wants to select a center town to restore his war-resources in which the total traffic capacities from the center to the other N - 1 towns is maximized. Now, you, the best programmer in the kingdom, should help our king to select this center.

Input

There are multiple test cases.

The first line of each case contains an integer N. (1 ≤ N ≤ 200,000)

The next N - 1 lines each contains three integers a, b, c indicating there is a road between town a and town b whose capacity is c. (1 ≤ a, b ≤ N, 1 ≤ c ≤ 100,000)

Output

For each test case, output an integer indicating the total traffic capacity of the chosen center town.

Sample Input

4
1 2 2
2 4 1
2 3 1
4
1 2 1
2 4 1
2 3 1

Sample Output

4
3

Contest: The 2012 ACM-ICPC Asia Changchun Regional Contest


听学长说是区域赛水题  

这就是传说中的区域赛签到题吗 

好啊不看题解我真的不会做

有一种“最大生成树”的感觉

不过百度了下最大生成树没有这道题

题意:给出n-1条边 问从一个点出发到其他点的边权的和最大是多少(到其他点的边权由路径上最小的边权决定)

思路:先按照给出的边从大到小排序 然后贪心

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
struct Edge
{
    int s,t;
    int len;
}edge[200200];
int cmp(Edge a,Edge b)
{
    return a.len>b.len;
}
struct Node
{
    int all;
    long long int sum;
}node[200200];
int father[200200];
int find(int x)
{
    if(father[x]!=x)
        father[x]=find(father[x]);
    return father[x];
}
int n;
int main()
{
    int i;
    long long int ans;
    while(scanf("%d",&n)!=EOF)
    {
        ans=0;
        for(i=1;i<n;i++)
        {
            scanf("%d %d %d",&edge[i].s,&edge[i].t,&edge[i].len);
        }
        sort(edge+1,edge+n,cmp);
        for(i=1;i<=n;i++)
        {
            father[i]=i;
            node[i].all=1;
            node[i].sum=0;
        }
        for(i=1;i<n;i++)
        {
            int fa=find(edge[i].s);
            int fb=find(edge[i].t);
            long long int s1=node[fb].sum+(long long int)edge[i].len*node[fa].all;
            long long int s2=node[fa].sum+(long long int)edge[i].len*node[fb].all;
            if(s1>=s2)
            {
                node[fa].sum=s1;
                node[fa].all+=node[fb].all;
                father[fb]=fa;
                if(ans<s1)
                    ans=s1;
            }
            else
            {
                node[fb].sum=s2;
                node[fb].all+=node[fa].all;
                father[fa]=fb;
                if(ans<s2)
                    ans=s2;
            }
        }
        printf("%lld\n",ans);
    }
    return 0;
}


Conquer a New Region

Time Limit: 5 Seconds      Memory Limit: 32768 KB

The wheel of the history rolling forward, our king conquered a new region in a distant continent.

There are N towns (numbered from 1 to N) in this region connected by several roads. It‘s confirmed that there is exact one route between any two towns. Traffic is important while controlled colonies are far away from the local country. We define the capacity C(i, j) of a road indicating it is allowed to transport at most C(i, j) goods between town i and town j if there is a road between them. And for a route between i and j, we define a value S(i, j) indicating the maximum traffic capacity between i and j which is equal to the minimum capacity of the roads on the route.

Our king wants to select a center town to restore his war-resources in which the total traffic capacities from the center to the other N - 1 towns is maximized. Now, you, the best programmer in the kingdom, should help our king to select this center.

Input

There are multiple test cases.

The first line of each case contains an integer N. (1 ≤ N ≤ 200,000)

The next N - 1 lines each contains three integers a, b, c indicating there is a road between town a and town b whose capacity is c. (1 ≤ a, b ≤ N, 1 ≤ c ≤ 100,000)

Output

For each test case, output an integer indicating the total traffic capacity of the chosen center town.

Sample Input

4
1 2 2
2 4 1
2 3 1
4
1 2 1
2 4 1
2 3 1

Sample Output

4
3

Contest: The 2012 ACM-ICPC Asia Changchun Regional Contest