首页 > 代码库 > poj3187Backward Digit Sums(DFS)

poj3187Backward Digit Sums(DFS)

题目链接:

huangjing

思路:

这个题目想到dfs很容易,但是纠结在这么像杨辉三角一样计算那些值,这个我看的队友的,简直厉害,用递归计算出杨辉三角顶端的值。。。。具体实现详见代码。。。


题目:

Language:
Backward Digit Sums
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 4285 Accepted: 2474

Description

FJ and his cows enjoy playing a mental game. They write down the numbers from 1 to N (1 <= N <= 10) in a certain order and then sum adjacent numbers to produce a new list with one fewer number. They repeat this until only a single number is left. For example, one instance of the game (when N=4) might go like this: 

    3   1   2   4

      4   3   6

        7   9

         16
Behind FJ‘s back, the cows have started playing a more difficult game, in which they try to determine the starting sequence from only the final total and the number N. Unfortunately, the game is a bit above FJ‘s mental arithmetic capabilities. 

Write a program to help FJ play the game and keep up with the cows.

Input

Line 1: Two space-separated integers: N and the final sum.

Output

Line 1: An ordering of the integers 1..N that leads to the given sum. If there are multiple solutions, choose the one that is lexicographically least, i.e., that puts smaller numbers first.

Sample Input

4 16

Sample Output

3 1 2 4

Hint

Explanation of the sample: 

There are other possible sequences, such as 3 2 1 4, but 3 1 2 4 is the lexicographically smallest.

Source

USACO 2006 February Gold & Silver


代码:
#include<cstdio>
#include<cstring>
const int maxn=10+10;

int a[maxn],ans[maxn],n,target,flag;
bool vis[maxn];

int forever(int n)
{
    if(n==0)  return a[0];
    for(int i=0;i<n-1;i++)
        a[i]=a[i]+a[i+1];
    return forever(n-1);
}

void dfs(int pos)
{
    if(flag)  return;
    if(pos==n)
    {
        for(int i=0;i<=n-1;i++)
            a[i]=ans[i];
        if(forever(n)==target)
        {
            flag=1;
            for(int i=0;i<n-1;i++)
                printf("%d ",ans[i]);
            printf("%d\n",a[n-1]);
        }
    }
    for(int i=1;i<=n;i++)
    {
        if(!vis[i])
        {
            vis[i]=true;
            ans[pos]=i;
            dfs(pos+1);
            vis[i]=false;
        }
    }
}


int main()
{
    while(~scanf("%d%d",&n,&target))
    {
       flag=0;
       memset(vis,false,sizeof(vis));
       for(int i=1;i<=n;i++)
       {
           ans[0]=i;
           vis[i]=true;
           dfs(1);
           vis[i]=false;
       }
    }
    return 0;
}