首页 > 代码库 > [BestCoder Round #6] hdu 4981 Goffi and Median (水题)
[BestCoder Round #6] hdu 4981 Goffi and Median (水题)
Goffi and Median
Problem Description
A median in a sequence with the length ofn is an element which occupies position number?n+12? after we sort the elements in the non-decreasing order (the elements are numbered starting with 1). A median of an array (2, 6, 1, 2, 3) is the number 2, and a median of array (0, 96, 17, 23) — the number 17.
An average of a sequence is the sum of sequence divided the size of the sequence.
Goffi likes median very much and he hates average number. So if a sequence‘s average number is larger than or equal to the median of sequence, Goffi will hate the sequence. Otherwise, Goffi will like it.
Now, your are given a sequence. Please find whether Goffi will like it or hate it.
Input
Input contains multiple test cases (less than 100). For each test case, the first line contains an integern (1≤n≤1000 ), indicating the size of the sequence. Then in the next line, there aren integersa1,a2,…,an (1≤ai≤1000 ), seperated by one space.
Output
For each case, if Goffi like the sequence, output "YES" in a line. Otherwise, output "NO".
Sample Input
5 1 2 3 4 5 4 1 5 6 6
Sample Output
NO YES
判断数字序列的中位数和平均数哪个大。
代码:
#include <iostream>
#include <stdio.h>
#include <algorithm>
#include <cmath>
#include <iomanip>
#include <queue>
#include <stack>
using namespace std;
const int maxn=1010;
int num[maxn];
int n;
int main()
{
while(scanf("%d",&n)!=EOF)
{
double ave;
double sum=0;
for(int i=1;i<=n;i++)
{
scanf("%d",&num[i]);
sum+=num[i];
}
sort(num+1,num+1+n);
int mid=(n+1)/2;
ave=sum/n;
if(ave>=num[mid])
printf("NO\n");
else
printf("YES\n");
}
return 0;
}
[BestCoder Round #6] hdu 4981 Goffi and Median (水题)
声明:以上内容来自用户投稿及互联网公开渠道收集整理发布,本网站不拥有所有权,未作人工编辑处理,也不承担相关法律责任,若内容有误或涉及侵权可进行投诉: 投诉/举报 工作人员会在5个工作日内联系你,一经查实,本站将立刻删除涉嫌侵权内容。