首页 > 代码库 > poj 2965 The Pilots Brothers' refrigerator(高斯消元)

poj 2965 The Pilots Brothers' refrigerator(高斯消元)

The Pilots Brothers‘ refrigerator
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 18641 Accepted: 7145 Special Judge

Description

The game “The Pilots Brothers: following the stripy elephant” has a quest where a player needs to open a refrigerator.

There are 16 handles on the refrigerator door. Every handle can be in one of two states: open or closed. The refrigerator is open only when all handles are open. The handles are represented as a matrix 4х4. You can change the state of a handle in any location [i, j] (1 ≤ i, j ≤ 4). However, this also changes states of all handles in row i and all handles in column j.

The task is to determine the minimum number of handle switching necessary to open the refrigerator.

Input

The input contains four lines. Each of the four lines contains four characters describing the initial state of appropriate handles. A symbol “+” means that the handle is in closed state, whereas the symbol “?” means “open”. At least one of the handles is initially closed.

Output

The first line of the input contains N – the minimum number of switching. The rest N lines describe switching sequence. Each of the lines contains a row number and a column number of the matrix separated by one or more spaces. If there are several solutions, you may give any one of them.

Sample Input

-+--
----
----
-+--

Sample Output

6
1 1
1 3
1 4
4 1
4 3
4 4

Source

Northeastern Europe 2004, Western Subregion


高斯消元的简单题:


#include <iostream>
#include <cstdio>
#include <cmath>
#include <cstring>
using namespace std;

int a[24][24],x[24];
int equ,var;//方程数和变元数
struct Locate
{
    int x,y;
}locate[24];

void Debug()
{
    for(int i=0; i<equ; i++)
    {
        for(int j=0; j<=var; j++)
            printf("%d ",a[i][j]);
        puts("");
    }
    puts("");
}

int gauss()
{
    int max_r,col=0;
    for(int i=0; i<equ&&col<var; i++,col++)
    {
        max_r=i;
        for(int j=i+1; j<equ; j++)
        {
            if(a[j][col]>a[max_r][col]) max_r=j;
        }
        if(max_r!=i)
        {
            for(int k=0; k<=var; k++)
            {
                swap(a[i][k],a[max_r][k]);
            }
        }
        if(a[i][col]==0)
        {
            i--;
            continue;
        }

        for(int j=i+1; j<equ; j++)
            if(i!=j&&a[j][col])
            {
                for(int k=col; k<=var; k++)
                    a[j][k]=a[i][k]^a[j][k];
            }
    }

    //Debug();

    int ans=0;
    for(int i=equ-1; i>=0; i--)
    {
        int temp=a[i][var];
        for(int j=i+1; j<var; j++)
        {
            temp-=a[i][j]*x[j];
        }
        x[i]=temp/a[i][i];
    }

    for(int i=0; i<var; i++)
    if(x[i]%2!=0)
    {
        locate[ans].x=i/4+1;
        locate[ans].y=i%4+1;
        ans++;
    }
    return ans;
}


void init()
{
    memset(a,0,sizeof(a));
    memset(x,0,sizeof(x));
    for(int i=0; i<4; i++)
        for(int j=0; j<4; j++)
        {
            for(int k=0; k<4; k++)
                a[i*4+j][k*4+j]=1;
            for(int k=0; k<4; k++)
                a[i*4+j][i*4+k]=1;
        }
    //Debug();
}
int main()
{
    equ=var=16;
    char s[20],t[6];
    memset(t,0,sizeof(t));
    memset(s,0,sizeof(s));
    while(scanf("%s",t)!=EOF)
    {
        strcpy(s,t);
        for(int i=0; i<3; i++)
        {
            scanf("%s",t);
            strcat(s,t);
        }
        init();
        for(int i=0; i<16; i++)
        {
            if(s[i]=='+') a[i][var]=1;
            else a[i][var]=0;
        }
        //Debug();
        int ans=gauss();
        printf("%d\n",ans);
        for(int i=0;i<ans;i++)
        {
            printf("%d %d\n",locate[i].x,locate[i].y);
        }
    }
    return 0;
}





poj 2965 The Pilots Brothers' refrigerator(高斯消元)