首页 > 代码库 > HDU 1002-A + B Problem II(大数类)

HDU 1002-A + B Problem II(大数类)

A + B Problem II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 215173    Accepted Submission(s): 41521


Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
 

Sample Input
2 1 2 112233445566778899 998877665544332211
 

Sample Output
Case 1: 1 + 2 = 3 Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110
BigInteger 一水。
import java.io.*;
import java.util.*;
import java.math.*;
public class Main {
       public static void main(String[] args){
    	   Scanner in=new Scanner(System.in);
    	   BigInteger a,b;int n,cas=1;
    	   n=in.nextInt();
    	   for(int i=0;i<n;i++){
    		   a=in.nextBigInteger();
    		   b=in.nextBigInteger();
    		   System.out.println("Case "+cas+":");
    		   ++cas;
    		   System.out.println(a+" + "+b+" = "+a.add(b));
    		   if(i!=n-1)
    		   System.out.println("");
    	   }
       }
}


HDU 1002-A + B Problem II(大数类)