首页 > 代码库 > HDU 1002 A + B Problem II

HDU 1002 A + B Problem II

A + B Problem II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 209025    Accepted Submission(s): 40177


Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
 

Sample Input
2 1 2 112233445566778899 998877665544332211
 

Sample Output
Case 1: 1 + 2 = 3 Case 2: 112233445566778899 + 998877665544332211 = 1111111111111111110
 



#include<stdio.h>
#include<string.h>
#define MAX 1005
int a1[MAX];
int a2[MAX];
char s1[MAX];
char s2[MAX];
int main()
{
	int n,t=1;
	scanf("%d",&n);
	while(n--)
	{
		int i,j,length1,length2;
		scanf("%s",s1);
		scanf("%s",s2);
		memset(a1,0,sizeof(a1));
		memset(a2,0,sizeof(a2));
		length1=strlen(s1);
		for(j=0,i=length1-1;i>=0;i--)
		a1[j++]=s1[i]-'0';
		length2=strlen(s2);
		for(j=0,i=length2-1;i>=0;i--)
		a2[j++]=s2[i]-'0';
		for(i=0;i<MAX;i++)
		{
			a1[i]=a1[i]+a2[i];
			if(a1[i]>=10)
			{a1[i]-=10;a1[i+1]++;}
		}
		printf("Case %d:\n",t++);
		printf("%s + %s = ",s1,s2);
		for(i=MAX;(i>=0)&&(a1[i]==0);i--);
		if(i>=0)
		{
			for(;i>=0;i--)
			printf("%d",a1[i]);
			printf("\n");
		}
		else
		printf("0\n");
		if(n>0)
		printf("\n"); 
	}
	return 0;	
}