首页 > 代码库 > A + B Problem II(杭电1002)
A + B Problem II(杭电1002)
/*A + B Problem II
Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
Sample Input
2
1 2
112233445566778899 998877665544332211
Sample Output
Case 1:
1 + 2 = 3
Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110*/
/*借鉴大神经验,与新手共勉。
*/
#include<stdio.h>
#include<string.h>
int main()
{
int str1[1100],str2[1100];
char a[1100],b[1100];
int test,i,j,t,k=1,len1,len2;
scanf("%d",&test);
getchar();
while(test--)
{
char sum[1100]={0};
scanf("%s %s",a,b);
getchar();
len1=strlen(a);
len2=strlen(b);
memset(str1,0,sizeof(str1));
memset(str2,0,sizeof(str2));
for(i=0,j=len1-1;i<len1;i++,j--)
str1[j]=a[i]-‘0‘;
for(i=0,j=len2-1;i<len2;i++,j--)
str2[j]=b[i]-‘0‘;
if(len1<len2)
{
t=len2;
len2=len1;
len1=t;
}
for(i=0;i<=len1;i++)
{
sum[i]=str1[i]+str2[i]+sum[i];
if(sum[i]/10>0)
{
sum[i+1]=sum[i]/10;
sum[i]=sum[i]%10;
}
}
printf("Case %d:\n",k);
k++;
printf("%s + %s = ",a,b);
if(sum[len1]!=0)
printf("%d",sum[len1]);
for(j=len1-1;j>=0;j--)
printf("%d",sum[j]);
printf("\n");
if(test!=0)
printf("\n");
}
while(1);
return 0;
}